summaryrefslogtreecommitdiffstats
path: root/debian/patches
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-06 01:22:32 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-06 01:22:32 +0000
commit0bbc0c292e607f3a40017a23d237c5d44eb30783 (patch)
tree550fdcacb3ba2f56c4a9cf93cab9581fd9b3ab97 /debian/patches
parentAdding upstream version 1.12.0. (diff)
downloadnetdata-0bbc0c292e607f3a40017a23d237c5d44eb30783.tar.xz
netdata-0bbc0c292e607f3a40017a23d237c5d44eb30783.zip
Adding debian version 1.12.0-1+deb10u1.debian/1.12.0-1+deb10u1debian
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'debian/patches')
-rw-r--r--debian/patches/debian/0001-use-system-python.patch131
-rw-r--r--debian/patches/debian/0002-use-system-exim4.patch12
-rw-r--r--debian/patches/debian/0003-use-python3.patch14
-rw-r--r--debian/patches/debian/0004-use-sh.patch12
-rw-r--r--debian/patches/debian/0005-remove-infographic.patch14
-rw-r--r--debian/patches/debian/0006-remove-contrib-files.patch49
-rw-r--r--debian/patches/debian/0007-remove-update-button.patch16
-rw-r--r--debian/patches/debian/0008-remove-social-media-buttons.patch18
-rw-r--r--debian/patches/debian/0009-remove-googleanalytics.patch11
-rw-r--r--debian/patches/debian/0010-remove-login.patch17
-rw-r--r--debian/patches/series11
-rw-r--r--debian/patches/upstream/0001-allow-symlinks.patch15
12 files changed, 320 insertions, 0 deletions
diff --git a/debian/patches/debian/0001-use-system-python.patch b/debian/patches/debian/0001-use-system-python.patch
new file mode 100644
index 0000000..f29b6c7
--- /dev/null
+++ b/debian/patches/debian/0001-use-system-python.patch
@@ -0,0 +1,131 @@
+Author: Lennart Weller <lhw@ring0.de>
+Description: Ignore embedded python modules.
+
+diff -Naurp netdata.orig/collectors/python.d.plugin/Makefile.am netdata/collectors/python.d.plugin/Makefile.am
+--- netdata.orig/collectors/python.d.plugin/Makefile.am
++++ netdata/collectors/python.d.plugin/Makefile.am
+@@ -138,109 +138,3 @@ dist_third_party_DATA = \
+ python_modules/third_party/boinc_client.py \
+ python_modules/third_party/monotonic.py \
+ $(NULL)
+-
+-pythonyaml2dir=$(pythonmodulesdir)/pyyaml2
+-dist_pythonyaml2_DATA = \
+- python_modules/pyyaml2/__init__.py \
+- python_modules/pyyaml2/composer.py \
+- python_modules/pyyaml2/constructor.py \
+- python_modules/pyyaml2/cyaml.py \
+- python_modules/pyyaml2/dumper.py \
+- python_modules/pyyaml2/emitter.py \
+- python_modules/pyyaml2/error.py \
+- python_modules/pyyaml2/events.py \
+- python_modules/pyyaml2/loader.py \
+- python_modules/pyyaml2/nodes.py \
+- python_modules/pyyaml2/parser.py \
+- python_modules/pyyaml2/reader.py \
+- python_modules/pyyaml2/representer.py \
+- python_modules/pyyaml2/resolver.py \
+- python_modules/pyyaml2/scanner.py \
+- python_modules/pyyaml2/serializer.py \
+- python_modules/pyyaml2/tokens.py \
+- $(NULL)
+-
+-pythonyaml3dir=$(pythonmodulesdir)/pyyaml3
+-dist_pythonyaml3_DATA = \
+- python_modules/pyyaml3/__init__.py \
+- python_modules/pyyaml3/composer.py \
+- python_modules/pyyaml3/constructor.py \
+- python_modules/pyyaml3/cyaml.py \
+- python_modules/pyyaml3/dumper.py \
+- python_modules/pyyaml3/emitter.py \
+- python_modules/pyyaml3/error.py \
+- python_modules/pyyaml3/events.py \
+- python_modules/pyyaml3/loader.py \
+- python_modules/pyyaml3/nodes.py \
+- python_modules/pyyaml3/parser.py \
+- python_modules/pyyaml3/reader.py \
+- python_modules/pyyaml3/representer.py \
+- python_modules/pyyaml3/resolver.py \
+- python_modules/pyyaml3/scanner.py \
+- python_modules/pyyaml3/serializer.py \
+- python_modules/pyyaml3/tokens.py \
+- $(NULL)
+-
+-python_urllib3dir=$(pythonmodulesdir)/urllib3
+-dist_python_urllib3_DATA = \
+- python_modules/urllib3/__init__.py \
+- python_modules/urllib3/_collections.py \
+- python_modules/urllib3/connection.py \
+- python_modules/urllib3/connectionpool.py \
+- python_modules/urllib3/exceptions.py \
+- python_modules/urllib3/fields.py \
+- python_modules/urllib3/filepost.py \
+- python_modules/urllib3/response.py \
+- python_modules/urllib3/poolmanager.py \
+- python_modules/urllib3/request.py \
+- $(NULL)
+-
+-python_urllib3_utildir=$(python_urllib3dir)/util
+-dist_python_urllib3_util_DATA = \
+- python_modules/urllib3/util/__init__.py \
+- python_modules/urllib3/util/connection.py \
+- python_modules/urllib3/util/request.py \
+- python_modules/urllib3/util/response.py \
+- python_modules/urllib3/util/retry.py \
+- python_modules/urllib3/util/selectors.py \
+- python_modules/urllib3/util/ssl_.py \
+- python_modules/urllib3/util/timeout.py \
+- python_modules/urllib3/util/url.py \
+- python_modules/urllib3/util/wait.py \
+- $(NULL)
+-
+-python_urllib3_packagesdir=$(python_urllib3dir)/packages
+-dist_python_urllib3_packages_DATA = \
+- python_modules/urllib3/packages/__init__.py \
+- python_modules/urllib3/packages/ordered_dict.py \
+- python_modules/urllib3/packages/six.py \
+- $(NULL)
+-
+-python_urllib3_backportsdir=$(python_urllib3_packagesdir)/backports
+-dist_python_urllib3_backports_DATA = \
+- python_modules/urllib3/packages/backports/__init__.py \
+- python_modules/urllib3/packages/backports/makefile.py \
+- $(NULL)
+-
+-python_urllib3_ssl_match_hostnamedir=$(python_urllib3_packagesdir)/ssl_match_hostname
+-dist_python_urllib3_ssl_match_hostname_DATA = \
+- python_modules/urllib3/packages/ssl_match_hostname/__init__.py \
+- python_modules/urllib3/packages/ssl_match_hostname/_implementation.py \
+- $(NULL)
+-
+-python_urllib3_contribdir=$(python_urllib3dir)/contrib
+-dist_python_urllib3_contrib_DATA = \
+- python_modules/urllib3/contrib/__init__.py \
+- python_modules/urllib3/contrib/appengine.py \
+- python_modules/urllib3/contrib/ntlmpool.py \
+- python_modules/urllib3/contrib/pyopenssl.py \
+- python_modules/urllib3/contrib/securetransport.py \
+- python_modules/urllib3/contrib/socks.py \
+- $(NULL)
+-
+-python_urllib3_securetransportdir=$(python_urllib3_contribdir)/_securetransport
+-dist_python_urllib3_securetransport_DATA = \
+- python_modules/urllib3/contrib/_securetransport/__init__.py \
+- python_modules/urllib3/contrib/_securetransport/bindings.py \
+- python_modules/urllib3/contrib/_securetransport/low_level.py \
+- $(NULL)
+diff -Naurp netdata.orig/collectors/python.d.plugin/python_modules/bases/loaders.py netdata/collectors/python.d.plugin/python_modules/bases/loaders.py
+--- netdata.orig/collectors/python.d.plugin/python_modules/bases/loaders.py
++++ netdata/collectors/python.d.plugin/python_modules/bases/loaders.py
+@@ -11,9 +11,9 @@ PY_VERSION = version_info[:2]
+
+ try:
+ if PY_VERSION > (3, 1):
+- from pyyaml3 import SafeLoader as YamlSafeLoader
++ from yaml import SafeLoader as YamlSafeLoader
+ else:
+- from pyyaml2 import SafeLoader as YamlSafeLoader
++ from yaml import SafeLoader as YamlSafeLoader
+ except ImportError:
+ from yaml import SafeLoader as YamlSafeLoader
+
diff --git a/debian/patches/debian/0002-use-system-exim4.patch b/debian/patches/debian/0002-use-system-exim4.patch
new file mode 100644
index 0000000..0e23618
--- /dev/null
+++ b/debian/patches/debian/0002-use-system-exim4.patch
@@ -0,0 +1,12 @@
+Author: Sven Hartge <sven@svenhartge.de>
+Description: Debian has exim in /usr/sbin which is not in the default path.
+
+diff -Naurp netdata.orig/collectors/python.d.plugin/exim/exim.conf netdata/collectors/python.d.plugin/exim/exim.conf
+--- netdata.orig/collectors/python.d.plugin/exim/exim.conf
++++ netdata/collectors/python.d.plugin/exim/exim.conf
+@@ -88,4 +88,4 @@ update_every: 10
+ # AUTO-DETECTION JOBS
+
+ local:
+- command: 'exim -bpc'
++ command: '/usr/sbin/exim -bpc'
diff --git a/debian/patches/debian/0003-use-python3.patch b/debian/patches/debian/0003-use-python3.patch
new file mode 100644
index 0000000..7359393
--- /dev/null
+++ b/debian/patches/debian/0003-use-python3.patch
@@ -0,0 +1,14 @@
+Author: Sander Klein <debian-bugs@roedie.nl>
+Description: Debian uses by default python 2 instead of python3.
+
+diff -Naurp netdata.orig/collectors/python.d.plugin/python.d.plugin.in netdata/collectors/python.d.plugin/python.d.plugin.in
+--- netdata.orig/collectors/python.d.plugin/python.d.plugin.in
++++ netdata/collectors/python.d.plugin/python.d.plugin.in
+@@ -1,6 +1,4 @@
+-#!/usr/bin/env bash
+-'''':; exec "$(command -v python || command -v python3 || command -v python2 ||
+-echo "ERROR python IS NOT AVAILABLE IN THIS SYSTEM")" "$0" "$@" # '''
++#!/usr/bin/python3
+
+ # -*- coding: utf-8 -*-
+ # Description:
diff --git a/debian/patches/debian/0004-use-sh.patch b/debian/patches/debian/0004-use-sh.patch
new file mode 100644
index 0000000..6c8e93b
--- /dev/null
+++ b/debian/patches/debian/0004-use-sh.patch
@@ -0,0 +1,12 @@
+Author: Daniel Baumann <daniel.baumann@progress-linux.org>
+Description: Fix shebang hack to not depend on bash.
+
+diff -Naurp netdata.orig/collectors/node.d.plugin/node.d.plugin.in netdata/collectors/node.d.plugin/node.d.plugin.in
+--- netdata.orig/collectors/node.d.plugin/node.d.plugin.in
++++ netdata/collectors/node.d.plugin/node.d.plugin.in
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env bash
++#!/bin/sh
+ ':' //; exec "$(command -v nodejs || command -v node || echo "ERROR node IS NOT AVAILABLE IN THIS SYSTEM")" "$0" "$@"
+
+ // shebang hack from:
diff --git a/debian/patches/debian/0005-remove-infographic.patch b/debian/patches/debian/0005-remove-infographic.patch
new file mode 100644
index 0000000..16b0d08
--- /dev/null
+++ b/debian/patches/debian/0005-remove-infographic.patch
@@ -0,0 +1,14 @@
+Author: Lennart Weller <lhw@ring0.de>
+Description: Remove infographic for privacy breach reasons.
+
+diff -Naurp netdata.orig/web/gui/Makefile.am netdata/web/gui/Makefile.am
+--- netdata.orig/web/gui/Makefile.am
++++ netdata/web/gui/Makefile.am
+@@ -61,7 +61,6 @@ dist_web_DATA = \
+ index.html \
+ main.css \
+ main.js \
+- infographic.html \
+ robots.txt \
+ refresh-badges.js \
+ sitemap.xml \
diff --git a/debian/patches/debian/0006-remove-contrib-files.patch b/debian/patches/debian/0006-remove-contrib-files.patch
new file mode 100644
index 0000000..f145aa0
--- /dev/null
+++ b/debian/patches/debian/0006-remove-contrib-files.patch
@@ -0,0 +1,49 @@
+Author: Lennart Weller <lhw@ring0.de>
+Description: Remove unused contrib files.
+
+diff -Naurp netdata.orig/web/gui/Makefile.am netdata/web/gui/Makefile.am
+--- netdata.orig/web/gui/Makefile.am
++++ netdata/web/gui/Makefile.am
+@@ -46,10 +46,6 @@ dist_noinst_DATA = \
+ $(NULL)
+
+ dist_web_DATA = \
+- demo.html \
+- demo2.html \
+- demosites.html \
+- demosites2.html \
+ dashboard.html \
+ dashboard.js \
+ dashboard_info.js \
+@@ -103,15 +99,6 @@ dist_webcss_DATA = \
+ css/c3-0.4.18.min.css \
+ $(NULL)
+
+-webfontsdir=$(webdir)/fonts
+-dist_webfonts_DATA = \
+- fonts/glyphicons-halflings-regular.eot \
+- fonts/glyphicons-halflings-regular.svg \
+- fonts/glyphicons-halflings-regular.ttf \
+- fonts/glyphicons-halflings-regular.woff \
+- fonts/glyphicons-halflings-regular.woff2 \
+- $(NULL)
+-
+ webimagesdir=$(webdir)/images
+ dist_webimages_DATA = \
+ images/netdata-logomark.svg \
+@@ -156,15 +143,6 @@ dashboard.js: $(DASHBOARD_JS_FILES)
+ if test -f $@; then rm -f $@; fi
+ cat $(DASHBOARD_JS_FILES) > $@.tmp && mv $@.tmp $@
+
+-webwellknowndir=$(webdir)/.well-known
+-dist_webwellknown_DATA = \
+- $(NULL)
+-
+-webdntdir=$(webdir)/.well-known/dnt
+-dist_webdnt_DATA = \
+- .well-known/dnt/cookies \
+- $(NULL)
+-
+ version.txt:
+ if test -d "$(top_srcdir)/.git"; then \
+ git --git-dir="$(top_srcdir)/.git" log -n 1 --format=%H; \
diff --git a/debian/patches/debian/0007-remove-update-button.patch b/debian/patches/debian/0007-remove-update-button.patch
new file mode 100644
index 0000000..b5d44e8
--- /dev/null
+++ b/debian/patches/debian/0007-remove-update-button.patch
@@ -0,0 +1,16 @@
+Author: Federico Ceratto <federico.ceratto@gmail.com>
+Description: Remove update button in web gui.
+
+diff -Naurp netdata.orig/web/gui/index.html netdata/web/gui/index.html
+--- netdata.orig/web/gui/index.html
++++ netdata/web/gui/index.html
+@@ -133,7 +133,9 @@
+ <ul class="nav navbar-nav">
+ <li id="alarmsButton" title="check the health monitoring alarms and their log" data-toggle="tooltip" data-placement="bottom"><a href="#" class="btn" data-toggle="modal" data-target="#alarmsModal"><i class="fas fa-bell"></i>&nbsp;<span class="hidden-sm hidden-md">Alarms&nbsp;</span><span id="alarms_count_badge" class="badge"></span></a></li>
+ <li title="change dashboard settings" data-toggle="tooltip" data-placement="bottom"><a href="#" class="btn" data-toggle="modal" data-target="#optionsModal"><i class="fas fa-cog"></i>&nbsp;<span class="hidden-sm hidden-md">Settings</span></a></li>
++ <!--
+ <li title="check for netdata updates<br/>you should keep your netdata updated" data-toggle="tooltip" data-placement="bottom" class="hidden-sm" id="updateButton"><a href="#" class="btn" data-toggle="modal" data-target="#updateModal"><i class="fas fa-cloud-download-alt"></i> <span class="hidden-sm hidden-md">Update </span><span id="update_badge" class="badge"></span></a></li>
++ -->
+ <li title="the netdata wiki home at github<br/>remember to <b>give netdata a <i class=&quot;fas fa-star&quot;></i></b> !" data-toggle="tooltip" data-placement="bottom" class="hidden-xs hidden-sm hidden-md"><a href="https://github.com/netdata/netdata" class="btn" target="_blank"><i class="fab fa-github"></i></a></li>
+ <li title="follow netdata on twitter" data-toggle="tooltip" data-placement="bottom" class="hidden-xs hidden-sm hidden-md"><a href="https://twitter.com/linuxnetdata" class="btn" target="_blank"><i class="fab fa-twitter"></i></a></li>
+ <li title="like netdata on facebook" data-toggle="tooltip" data-placement="bottom" class="hidden-xs hidden-sm hidden-md"><a href="https://www.facebook.com/linuxnetdata/" class="btn" target="_blank"><i class="fab fa-facebook"></i></a></li>
diff --git a/debian/patches/debian/0008-remove-social-media-buttons.patch b/debian/patches/debian/0008-remove-social-media-buttons.patch
new file mode 100644
index 0000000..9b5f05e
--- /dev/null
+++ b/debian/patches/debian/0008-remove-social-media-buttons.patch
@@ -0,0 +1,18 @@
+Author: Daniel Baumann <daniel.baumann@progress-linux.org>
+Description: Remove social media buttons in web gui.
+
+diff -Naurp netdata.orig/web/gui/index.html netdata/web/gui/index.html
+--- netdata.orig/web/gui/index.html
++++ netdata/web/gui/index.html
+@@ -136,9 +136,11 @@
+ <!--
+ <li title="check for netdata updates<br/>you should keep your netdata updated" data-toggle="tooltip" data-placement="bottom" class="hidden-sm" id="updateButton"><a href="#" class="btn" data-toggle="modal" data-target="#updateModal"><i class="fas fa-cloud-download-alt"></i> <span class="hidden-sm hidden-md">Update </span><span id="update_badge" class="badge"></span></a></li>
+ -->
++ <!--
+ <li title="the netdata wiki home at github<br/>remember to <b>give netdata a <i class=&quot;fas fa-star&quot;></i></b> !" data-toggle="tooltip" data-placement="bottom" class="hidden-xs hidden-sm hidden-md"><a href="https://github.com/netdata/netdata" class="btn" target="_blank"><i class="fab fa-github"></i></a></li>
+ <li title="follow netdata on twitter" data-toggle="tooltip" data-placement="bottom" class="hidden-xs hidden-sm hidden-md"><a href="https://twitter.com/linuxnetdata" class="btn" target="_blank"><i class="fab fa-twitter"></i></a></li>
+ <li title="like netdata on facebook" data-toggle="tooltip" data-placement="bottom" class="hidden-xs hidden-sm hidden-md"><a href="https://www.facebook.com/linuxnetdata/" class="btn" target="_blank"><i class="fab fa-facebook"></i></a></li>
++ -->
+ <li title="import / load a netdata snapshot" data-toggle="tooltip" data-placement="bottom" id="loadButton"><a href="#" class="btn" data-toggle="modal" data-target="#loadSnapshotModal"><i class="fas fa-download"></i>&nbsp;<span class="hidden-sm hidden-md hidden-lg">Import</span></a></li>
+ <li title="export / save a netdata snapshot" data-toggle="tooltip" data-placement="bottom" id="saveButton"><a href="#" class="btn" data-toggle="modal" data-target="#saveSnapshotModal"><i class="fas fa-upload"></i>&nbsp;<span class="hidden-sm hidden-md hidden-lg">Export</span></a></li>
+ <li title="print this dashboard to PDF" data-toggle="tooltip" data-placement="bottom" id="printButton"><a href="#" class="btn" data-toggle="modal" data-target="#printPreflightModal"><i class="fas fa-print"></i>&nbsp;<span class="hidden-sm hidden-md hidden-lg">Print</span></a></li>
diff --git a/debian/patches/debian/0009-remove-googleanalytics.patch b/debian/patches/debian/0009-remove-googleanalytics.patch
new file mode 100644
index 0000000..aa6f0e9
--- /dev/null
+++ b/debian/patches/debian/0009-remove-googleanalytics.patch
@@ -0,0 +1,11 @@
+Author: Lennart Weller <lhw@ring0.de>
+Subject: Remove googleanalytics
+
+diff -Naurp netdata.orig/docs/generator/custom/themes/material/partials/footer.html netdata/docs/generator/custom/themes/material/partials/footer.html
+--- netdata.orig/docs/generator/custom/themes/material/partials/footer.html
++++ netdata/docs/generator/custom/themes/material/partials/footer.html
+@@ -51,4 +51,3 @@
+ </div>
+ </div>
+ </footer>
+-<script>!function(e,a,t,n,o,c,i){e.GoogleAnalyticsObject=o,e.ga=e.ga||function(){(e.ga.q=e.ga.q||[]).push(arguments)},e.ga.l=1*new Date,c=a.createElement(t),i=a.getElementsByTagName(t)[0],c.async=1,c.src="https://www.google-analytics.com/analytics.js",i.parentNode.insertBefore(c,i)}(window,document,"script",0,"ga"),ga("create","UA-64295674-3",""),ga("set","anonymizeIp",!0),ga("send","pageview","/doc"+window.location.pathname);var links=document.getElementsByTagName("a");if(Array.prototype.map.call(links,function(a){a.host!=document.location.host&&a.addEventListener("click",function(){var e=a.getAttribute("data-md-action")||"follow";ga("send","event","outbound",e,a.href)})}),document.forms.search){var query=document.forms.search.query;query.addEventListener("blur",function(){if(this.value){var e=document.location.pathname;ga("send","pageview",e+"?q="+this.value)}})}</script>
diff --git a/debian/patches/debian/0010-remove-login.patch b/debian/patches/debian/0010-remove-login.patch
new file mode 100644
index 0000000..74b5e06
--- /dev/null
+++ b/debian/patches/debian/0010-remove-login.patch
@@ -0,0 +1,17 @@
+Author: Federico Ceratto <federico@debian.org>
+Description: remove Sign In button from main HTML page
+
+diff -Naurp netdata.orig/web/gui/main.js netdata/web/gui/main.js
+--- netdata.orig/web/gui/main.js
++++ netdata/web/gui/main.js
+@@ -4758,9 +4758,7 @@ function renderAccountUI() {
+ container.setAttribute("data-original-title", "sign in");
+ container.setAttribute("data-placement", "bottom");
+ container.innerHTML = (
+- `<a href="#" class="btn" onclick="signInDidClick(event); return false">
+- <i class="fas fa-sign-in-alt"></i>&nbsp;<span class="hidden-sm hidden-md">Sign In</span>
+- </a>`
++ ``
+ )
+ }
+ }
diff --git a/debian/patches/series b/debian/patches/series
new file mode 100644
index 0000000..181a145
--- /dev/null
+++ b/debian/patches/series
@@ -0,0 +1,11 @@
+debian/0001-use-system-python.patch
+debian/0002-use-system-exim4.patch
+debian/0003-use-python3.patch
+debian/0004-use-sh.patch
+debian/0005-remove-infographic.patch
+debian/0006-remove-contrib-files.patch
+debian/0007-remove-update-button.patch
+debian/0008-remove-social-media-buttons.patch
+debian/0009-remove-googleanalytics.patch
+debian/0010-remove-login.patch
+upstream/0001-allow-symlinks.patch
diff --git a/debian/patches/upstream/0001-allow-symlinks.patch b/debian/patches/upstream/0001-allow-symlinks.patch
new file mode 100644
index 0000000..bfc589b
--- /dev/null
+++ b/debian/patches/upstream/0001-allow-symlinks.patch
@@ -0,0 +1,15 @@
+Author: Lennart Weller <lhw@ring0.de>
+Description: Remove file serve restrictions for symlinks.
+
+diff -Naurp netdata.orig/web/server/web_client.c netdata/web/server/web_client.c
+--- netdata.orig/web/server/web_client.c
++++ netdata/web/server/web_client.c
+@@ -376,7 +376,7 @@ int mysendfile(struct web_client *w, cha
+ int done = 0;
+ while(!done) {
+ // check if the file exists
+- if (lstat(webfilename, &statbuf) != 0) {
++ if (stat(webfilename, &statbuf) != 0) {
+ debug(D_WEB_CLIENT_ACCESS, "%llu: File '%s' is not found.", w->id, webfilename);
+ w->response.data->contenttype = CT_TEXT_HTML;
+ buffer_strcat(w->response.data, "File does not exist, or is not accessible: ");