summaryrefslogtreecommitdiffstats
path: root/debian/patches/30_shared_libs.diff
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-06 01:46:31 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-06 01:46:31 +0000
commit32afea41ba8b7328e252ae97ca32c56f98d42a90 (patch)
tree11b25ffd59d9190c8316cd48ace4e198531d0e7d /debian/patches/30_shared_libs.diff
parentAdding upstream version 3.4.23. (diff)
downloadpostfix-32afea41ba8b7328e252ae97ca32c56f98d42a90.tar.xz
postfix-32afea41ba8b7328e252ae97ca32c56f98d42a90.zip
Adding debian version 3.4.23-0+deb10u1.debian/3.4.23-0+deb10u1debian
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'debian/patches/30_shared_libs.diff')
-rw-r--r--debian/patches/30_shared_libs.diff54
1 files changed, 54 insertions, 0 deletions
diff --git a/debian/patches/30_shared_libs.diff b/debian/patches/30_shared_libs.diff
new file mode 100644
index 0000000..801c090
--- /dev/null
+++ b/debian/patches/30_shared_libs.diff
@@ -0,0 +1,54 @@
+Index: postfix/src/dns/Makefile.in
+===================================================================
+--- postfix.orig/src/dns/Makefile.in
++++ postfix/src/dns/Makefile.in
+@@ -63,7 +63,7 @@ root_tests:
+ $(LIB): $(OBJS)
+ $(AR) $(ARFL) $(LIB) $?
+ $(RANLIB) $(LIB)
+- $(SHLIB_LD) $(SHLIB_RPATH) -o $(LIB) $(OBJS) $(SHLIB_SYSLIBS)
++ $(SHLIB_LD) $(SHLIB_RPATH) -o $(LIB) $(OBJS) $(SHLIB_SYSLIBS) -L../../lib -lpostfix-util -lpostfix-global
+
+ $(LIB_DIR)/$(LIB): $(LIB)
+ cp $(LIB) $(LIB_DIR)
+Index: postfix/src/global/Makefile.in
+===================================================================
+--- postfix.orig/src/global/Makefile.in
++++ postfix/src/global/Makefile.in
+@@ -144,7 +144,7 @@ test: $(TESTPROG)
+ $(LIB): $(OBJS)
+ $(AR) $(ARFL) $(LIB) $?
+ $(RANLIB) $(LIB)
+- $(SHLIB_LD) $(SHLIB_RPATH) -o $(LIB) $(OBJS) $(SHLIB_SYSLIBS)
++ $(SHLIB_LD) $(SHLIB_RPATH) -o $(LIB) $(OBJS) $(SHLIB_SYSLIBS) -L../../lib -lpostfix-util
+
+ $(LIB_DIR)/$(LIB): $(LIB)
+ cp $(LIB) $(LIB_DIR)
+Index: postfix/src/master/Makefile.in
+===================================================================
+--- postfix.orig/src/master/Makefile.in
++++ postfix/src/master/Makefile.in
+@@ -44,7 +44,8 @@ root_tests:
+ $(LIB): $(LIB_OBJ)
+ $(AR) $(ARFL) $(LIB) $?
+ $(RANLIB) $(LIB)
+- $(SHLIB_LD) $(SHLIB_RPATH) -o $(LIB) $(LIB_OBJ) $(SHLIB_SYSLIBS)
++ $(SHLIB_LD) $(SHLIB_RPATH) -o $(LIB) $(LIB_OBJ) $(SHLIB_SYSLIBS) \
++ -L../../lib -lpostfix-global -lpostfix-util
+
+ $(LIB_DIR)/$(LIB): $(LIB)
+ cp $(LIB) $(LIB_DIR)/$(LIB)
+Index: postfix/src/tls/Makefile.in
+===================================================================
+--- postfix.orig/src/tls/Makefile.in
++++ postfix/src/tls/Makefile.in
+@@ -81,7 +81,8 @@ root_tests:
+ $(LIB): $(OBJS)
+ $(AR) $(ARFL) $(LIB) $?
+ $(RANLIB) $(LIB)
+- $(SHLIB_LD) $(SHLIB_RPATH) -o $(LIB) $(OBJS) $(SHLIB_SYSLIBS)
++ $(SHLIB_LD) $(SHLIB_RPATH) -o $(LIB) $(OBJS) $(SHLIB_SYSLIBS) \
++ -L../../lib -lpostfix-dns -lpostfix-global -lpostfix-util
+
+ $(LIB_DIR)/$(LIB): $(LIB)
+ cp $(LIB) $(LIB_DIR)