summaryrefslogtreecommitdiffstats
path: root/dh_make_pgxs/debian
diff options
context:
space:
mode:
Diffstat (limited to 'dh_make_pgxs/debian')
-rw-r--r--dh_make_pgxs/debian/compat1
-rw-r--r--dh_make_pgxs/debian/control.in16
-rw-r--r--dh_make_pgxs/debian/copyright24
-rw-r--r--dh_make_pgxs/debian/pgversions1
-rwxr-xr-xdh_make_pgxs/debian/rules21
-rw-r--r--dh_make_pgxs/debian/source/format1
-rw-r--r--dh_make_pgxs/debian/tests/control3
-rwxr-xr-xdh_make_pgxs/debian/tests/installcheck2
8 files changed, 69 insertions, 0 deletions
diff --git a/dh_make_pgxs/debian/compat b/dh_make_pgxs/debian/compat
new file mode 100644
index 0000000..57d1b61
--- /dev/null
+++ b/dh_make_pgxs/debian/compat
@@ -0,0 +1 @@
+@COMPAT@
diff --git a/dh_make_pgxs/debian/control.in b/dh_make_pgxs/debian/control.in
new file mode 100644
index 0000000..d77bd1b
--- /dev/null
+++ b/dh_make_pgxs/debian/control.in
@@ -0,0 +1,16 @@
+Source: @SOURCE@
+Section: database
+Priority: optional
+Maintainer: Debian PostgreSQL Maintainers <team+postgresql@tracker.debian.org>
+Uploaders: @MAINTAINER_NAME@ <@DEBEMAIL@>
+Build-Depends: debhelper (>= @COMPAT@), postgresql-server-dev-all (>= 153~)
+Standards-Version: @STANDARDS_VERSION@
+Vcs-Browser: https://salsa.debian.org/postgresql/@SOURCE@
+Vcs-Git: https://salsa.debian.org/postgresql/@SOURCE@.git
+#Homepage: @URL@
+
+Package: postgresql-PGVERSION-@EXTNAME@
+Architecture: any
+Depends: postgresql-PGVERSION, ${misc:Depends}, ${shlibs:Depends}
+Description: FIXME PostgreSQL extension @SOURCE@
+ FIXME long description here
diff --git a/dh_make_pgxs/debian/copyright b/dh_make_pgxs/debian/copyright
new file mode 100644
index 0000000..be674ea
--- /dev/null
+++ b/dh_make_pgxs/debian/copyright
@@ -0,0 +1,24 @@
+Format: https://www.debian.org/doc/packaging-manuals/copyright-format/1.0/
+Upstream-Name: @NAME@
+#Source: @URL@
+
+Files: *
+Copyright: Portions Copyright (c) 1996-2018, PostgreSQL Global Development Group
+ Portions Copyright (c) 1994, The Regents of the University of California
+License: PostgreSQL
+ Permission to use, copy, modify, and distribute this software and its
+ documentation for any purpose, without fee, and without a written agreement
+ is hereby granted, provided that the above copyright notice and this
+ paragraph and the following two paragraphs appear in all copies.
+ .
+ IN NO EVENT SHALL THE UNIVERSITY OF CALIFORNIA BE LIABLE TO ANY PARTY FOR
+ DIRECT, INDIRECT, SPECIAL, INCIDENTAL, OR CONSEQUENTIAL DAMAGES, INCLUDING
+ LOST PROFITS, ARISING OUT OF THE USE OF THIS SOFTWARE AND ITS
+ DOCUMENTATION, EVEN IF THE UNIVERSITY OF CALIFORNIA HAS BEEN ADVISED OF THE
+ POSSIBILITY OF SUCH DAMAGE.
+ .
+ THE UNIVERSITY OF CALIFORNIA SPECIFICALLY DISCLAIMS ANY WARRANTIES,
+ INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY
+ AND FITNESS FOR A PARTICULAR PURPOSE. THE SOFTWARE PROVIDED HEREUNDER IS
+ ON AN "AS IS" BASIS, AND THE UNIVERSITY OF CALIFORNIA HAS NO OBLIGATIONS TO
+ PROVIDE MAINTENANCE, SUPPORT, UPDATES, ENHANCEMENTS, OR MODIFICATIONS.
diff --git a/dh_make_pgxs/debian/pgversions b/dh_make_pgxs/debian/pgversions
new file mode 100644
index 0000000..0702cb5
--- /dev/null
+++ b/dh_make_pgxs/debian/pgversions
@@ -0,0 +1 @@
+all
diff --git a/dh_make_pgxs/debian/rules b/dh_make_pgxs/debian/rules
new file mode 100755
index 0000000..7b28bd8
--- /dev/null
+++ b/dh_make_pgxs/debian/rules
@@ -0,0 +1,21 @@
+#!/usr/bin/make -f
+
+include /usr/share/postgresql-common/pgxs_debian_control.mk
+
+override_dh_auto_build:
+ +pg_buildext build build-%v
+
+override_dh_auto_test:
+ # nothing to do here, see debian/tests/* instead
+
+override_dh_auto_install:
+ +pg_buildext install build-%v postgresql-%v-@EXTNAME@
+
+override_dh_installdocs:
+ dh_installdocs --all README.*
+
+override_dh_auto_clean:
+ +pg_buildext clean build-%v
+
+%:
+ dh $@
diff --git a/dh_make_pgxs/debian/source/format b/dh_make_pgxs/debian/source/format
new file mode 100644
index 0000000..163aaf8
--- /dev/null
+++ b/dh_make_pgxs/debian/source/format
@@ -0,0 +1 @@
+3.0 (quilt)
diff --git a/dh_make_pgxs/debian/tests/control b/dh_make_pgxs/debian/tests/control
new file mode 100644
index 0000000..b0dc4e8
--- /dev/null
+++ b/dh_make_pgxs/debian/tests/control
@@ -0,0 +1,3 @@
+Depends: @, postgresql-server-dev-all
+Tests: installcheck
+Restrictions: allow-stderr
diff --git a/dh_make_pgxs/debian/tests/installcheck b/dh_make_pgxs/debian/tests/installcheck
new file mode 100755
index 0000000..32dafbc
--- /dev/null
+++ b/dh_make_pgxs/debian/tests/installcheck
@@ -0,0 +1,2 @@
+#!/bin/sh
+pg_buildext installcheck