summaryrefslogtreecommitdiffstats
path: root/sysusers.d/meson.build
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-06 02:25:50 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-06 02:25:50 +0000
commit19f4f86bfed21c5326ed2acebe1163f3a83e832b (patch)
treed59b9989ce55ed23693e80974d94c856f1c2c8b1 /sysusers.d/meson.build
parentInitial commit. (diff)
downloadsystemd-19f4f86bfed21c5326ed2acebe1163f3a83e832b.tar.xz
systemd-19f4f86bfed21c5326ed2acebe1163f3a83e832b.zip
Adding upstream version 241.upstream/241upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'sysusers.d/meson.build')
-rw-r--r--sysusers.d/meson.build33
1 files changed, 33 insertions, 0 deletions
diff --git a/sysusers.d/meson.build b/sysusers.d/meson.build
new file mode 100644
index 0000000..eb99957
--- /dev/null
+++ b/sysusers.d/meson.build
@@ -0,0 +1,33 @@
+# SPDX-License-Identifier: LGPL-2.1+
+
+in_files = ['basic.conf']
+
+enable_sysusers = conf.get('ENABLE_SYSUSERS') == 1
+
+foreach file : in_files
+ gen = configure_file(
+ input : file + '.in',
+ output : file,
+ configuration : substs)
+ if enable_sysusers
+ install_data(gen,
+ install_dir : sysusersdir)
+ endif
+endforeach
+
+m4_files = ['systemd.conf']
+
+if conf.get('ENABLE_REMOTE') == 1 and conf.get('HAVE_MICROHTTPD') == 1
+ m4_files += ['systemd-remote.conf']
+endif
+
+foreach file : m4_files
+ custom_target(
+ 'sysusers.d_' + file,
+ input : file + '.m4',
+ output: file,
+ command : [meson_apply_m4, config_h, '@INPUT@'],
+ capture : true,
+ install : enable_sysusers,
+ install_dir : sysusersdir)
+endforeach