summaryrefslogtreecommitdiffstats
path: root/sysusers.d
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-06 02:25:50 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-06 02:25:50 +0000
commit19f4f86bfed21c5326ed2acebe1163f3a83e832b (patch)
treed59b9989ce55ed23693e80974d94c856f1c2c8b1 /sysusers.d
parentInitial commit. (diff)
downloadsystemd-19f4f86bfed21c5326ed2acebe1163f3a83e832b.tar.xz
systemd-19f4f86bfed21c5326ed2acebe1163f3a83e832b.zip
Adding upstream version 241.upstream/241upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'sysusers.d')
-rw-r--r--sysusers.d/basic.conf.in38
-rw-r--r--sysusers.d/meson.build33
-rw-r--r--sysusers.d/systemd-remote.conf.m410
-rw-r--r--sysusers.d/systemd.conf.m420
4 files changed, 101 insertions, 0 deletions
diff --git a/sysusers.d/basic.conf.in b/sysusers.d/basic.conf.in
new file mode 100644
index 0000000..8e358c0
--- /dev/null
+++ b/sysusers.d/basic.conf.in
@@ -0,0 +1,38 @@
+# This file is part of systemd.
+#
+# systemd is free software; you can redistribute it and/or modify it
+# under the terms of the GNU Lesser General Public License as published by
+# the Free Software Foundation; either version 2.1 of the License, or
+# (at your option) any later version.
+
+# The superuser
+u root 0 "Super User" /root
+
+# The nobody user for NFS file systems
+u @NOBODY_USER_NAME@ 65534 "Nobody" -
+
+# Administrator group: can *see* more than normal users
+g adm - - -
+
+# Administrator group: can *do* more than normal users
+g wheel - - -
+
+# Access to certain kernel and userspace facilities
+g kmem - - -
+g tty @TTY_GID@ - -
+g utmp - - -
+
+# Hardware access groups
+g audio - - -
+g cdrom - - -
+g dialout - - -
+g disk - - -
+g input - - -
+g kvm - - -
+g lp - - -
+g render - - -
+g tape - - -
+g video - - -
+
+# Default group for normal users
+g users @USERS_GID@ - -
diff --git a/sysusers.d/meson.build b/sysusers.d/meson.build
new file mode 100644
index 0000000..eb99957
--- /dev/null
+++ b/sysusers.d/meson.build
@@ -0,0 +1,33 @@
+# SPDX-License-Identifier: LGPL-2.1+
+
+in_files = ['basic.conf']
+
+enable_sysusers = conf.get('ENABLE_SYSUSERS') == 1
+
+foreach file : in_files
+ gen = configure_file(
+ input : file + '.in',
+ output : file,
+ configuration : substs)
+ if enable_sysusers
+ install_data(gen,
+ install_dir : sysusersdir)
+ endif
+endforeach
+
+m4_files = ['systemd.conf']
+
+if conf.get('ENABLE_REMOTE') == 1 and conf.get('HAVE_MICROHTTPD') == 1
+ m4_files += ['systemd-remote.conf']
+endif
+
+foreach file : m4_files
+ custom_target(
+ 'sysusers.d_' + file,
+ input : file + '.m4',
+ output: file,
+ command : [meson_apply_m4, config_h, '@INPUT@'],
+ capture : true,
+ install : enable_sysusers,
+ install_dir : sysusersdir)
+endforeach
diff --git a/sysusers.d/systemd-remote.conf.m4 b/sysusers.d/systemd-remote.conf.m4
new file mode 100644
index 0000000..9889176
--- /dev/null
+++ b/sysusers.d/systemd-remote.conf.m4
@@ -0,0 +1,10 @@
+# This file is part of systemd.
+#
+# systemd is free software; you can redistribute it and/or modify it
+# under the terms of the GNU Lesser General Public License as published by
+# the Free Software Foundation; either version 2.1 of the License, or
+# (at your option) any later version.
+
+m4_ifdef(`HAVE_MICROHTTPD',
+u systemd-journal-remote - "systemd Journal Remote"
+)m4_dnl
diff --git a/sysusers.d/systemd.conf.m4 b/sysusers.d/systemd.conf.m4
new file mode 100644
index 0000000..ef5a3cb
--- /dev/null
+++ b/sysusers.d/systemd.conf.m4
@@ -0,0 +1,20 @@
+# This file is part of systemd.
+#
+# systemd is free software; you can redistribute it and/or modify it
+# under the terms of the GNU Lesser General Public License as published by
+# the Free Software Foundation; either version 2.1 of the License, or
+# (at your option) any later version.
+
+g systemd-journal - -
+m4_ifdef(`ENABLE_NETWORKD',
+u systemd-network - "systemd Network Management"
+)m4_dnl
+m4_ifdef(`ENABLE_RESOLVE',
+u systemd-resolve - "systemd Resolver"
+)m4_dnl
+m4_ifdef(`ENABLE_TIMESYNCD',
+u systemd-timesync - "systemd Time Synchronization"
+)m4_dnl
+m4_ifdef(`ENABLE_COREDUMP',
+u systemd-coredump - "systemd Core Dumper"
+)m4_dnl