summaryrefslogtreecommitdiffstats
path: root/src/Makefile.kmk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-06 03:01:46 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-06 03:01:46 +0000
commitf8fe689a81f906d1b91bb3220acde2a4ecb14c5b (patch)
tree26484e9d7e2c67806c2d1760196ff01aaa858e8c /src/Makefile.kmk
parentInitial commit. (diff)
downloadvirtualbox-f8fe689a81f906d1b91bb3220acde2a4ecb14c5b.tar.xz
virtualbox-f8fe689a81f906d1b91bb3220acde2a4ecb14c5b.zip
Adding upstream version 6.0.4-dfsg.upstream/6.0.4-dfsgupstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/Makefile.kmk')
-rw-r--r--src/Makefile.kmk40
1 files changed, 40 insertions, 0 deletions
diff --git a/src/Makefile.kmk b/src/Makefile.kmk
new file mode 100644
index 00000000..c489f538
--- /dev/null
+++ b/src/Makefile.kmk
@@ -0,0 +1,40 @@
+# $Id: Makefile.kmk $
+## @file
+# Top-level makefile for the src directory.
+#
+
+#
+# Copyright (C) 2006-2019 Oracle Corporation
+#
+# This file is part of VirtualBox Open Source Edition (OSE), as
+# available from http://www.virtualbox.org. This file is free software;
+# you can redistribute it and/or modify it under the terms of the GNU
+# General Public License (GPL) as published by the Free Software
+# Foundation, in version 2 as it comes in the "COPYING" file of the
+# VirtualBox OSE distribution. VirtualBox OSE is distributed in the
+# hope that it will be useful, but WITHOUT ANY WARRANTY of any kind.
+#
+
+SUB_DEPTH = ..
+include $(KBUILD_PATH)/subheader.kmk
+
+include $(PATH_SUB_CURRENT)/bldprogs/Makefile.kmk
+include $(PATH_SUB_CURRENT)/VBox/Makefile.kmk
+include $(PATH_SUB_CURRENT)/libs/Makefile.kmk
+if defined(VBOX_ONLY_EXTPACKS) && !defined(VBOX_ONLY_EXTPACKS_USE_IMPLIBS) && defined(VBOX_WITH_REM)
+ include $(PATH_SUB_CURRENT)/recompiler/Makefile.kmk
+
+else if !defined(VBOX_ONLY_BUILD)
+ # Normal build.
+ if1of ($(KBUILD_TARGET_ARCH), x86 amd64)
+ ifdef VBOX_WITH_REM
+ include $(PATH_SUB_CURRENT)/recompiler/Makefile.kmk
+ endif
+ endif
+ ifneq ($(wildcard $(PATH_SUB_CURRENT)/apps),)
+ include $(PATH_SUB_CURRENT)/apps/Makefile.kmk
+ endif
+endif # !VBOX_ONLY_BUILD
+
+include $(FILE_KBUILD_SUB_FOOTER)
+