summaryrefslogtreecommitdiffstats
path: root/src/VBox/Devices/BiosCommonCode/Makefile.kmk
diff options
context:
space:
mode:
Diffstat (limited to 'src/VBox/Devices/BiosCommonCode/Makefile.kmk')
-rw-r--r--src/VBox/Devices/BiosCommonCode/Makefile.kmk33
1 files changed, 33 insertions, 0 deletions
diff --git a/src/VBox/Devices/BiosCommonCode/Makefile.kmk b/src/VBox/Devices/BiosCommonCode/Makefile.kmk
new file mode 100644
index 00000000..d8859e1b
--- /dev/null
+++ b/src/VBox/Devices/BiosCommonCode/Makefile.kmk
@@ -0,0 +1,33 @@
+# $Id: Makefile.kmk $
+## @file
+# Sub-Makefile for the New BIOS ROM.
+#
+
+#
+# Copyright (C) 2012-2019 Oracle Corporation
+#
+# This file is part of VirtualBox Open Source Edition (OSE), as
+# available from http://www.virtualbox.org. This file is free software;
+# you can redistribute it and/or modify it under the terms of the GNU
+# General Public License (GPL) as published by the Free Software
+# Foundation, in version 2 as it comes in the "COPYING" file of the
+# VirtualBox OSE distribution. VirtualBox OSE is distributed in the
+# hope that it will be useful, but WITHOUT ANY WARRANTY of any kind.
+#
+
+SUB_DEPTH = ../../../..
+include $(KBUILD_PATH)/subheader.kmk
+
+#
+# MakeAlternative - For distros without OpenWatcom.
+#
+BLDPROGS += MakeAlternativeSource
+MakeAlternativeSource_TEMPLATE = VBoxAdvBldProg
+MakeAlternativeSource_DEFS = IN_DIS
+MakeAlternativeSource_SOURCES = MakeAlternativeSource.cpp
+MakeAlternativeSource_LIBS = \
+ $(PATH_STAGE_LIB)/DisasmBldProg$(VBOX_HOSTSUFF_LIB)
+
+
+include $(FILE_KBUILD_SUB_FOOTER)
+