summaryrefslogtreecommitdiffstats
path: root/src/VBox/Frontends/VBoxBugReport/Makefile.kmk
diff options
context:
space:
mode:
Diffstat (limited to 'src/VBox/Frontends/VBoxBugReport/Makefile.kmk')
-rw-r--r--src/VBox/Frontends/VBoxBugReport/Makefile.kmk35
1 files changed, 35 insertions, 0 deletions
diff --git a/src/VBox/Frontends/VBoxBugReport/Makefile.kmk b/src/VBox/Frontends/VBoxBugReport/Makefile.kmk
new file mode 100644
index 00000000..c5dd8b8f
--- /dev/null
+++ b/src/VBox/Frontends/VBoxBugReport/Makefile.kmk
@@ -0,0 +1,35 @@
+# $Id: Makefile.kmk $
+## @file
+# Sub-Makefile for VBoxBugReport
+#
+# VBoxBugReport is a tool for collecting useful information on the host.
+#
+
+#
+# Copyright (C) 2006-2019 Oracle Corporation
+#
+# This file is part of VirtualBox Open Source Edition (OSE), as
+# available from http://www.virtualbox.org. This file is free software;
+# you can redistribute it and/or modify it under the terms of the GNU
+# General Public License (GPL) as published by the Free Software
+# Foundation, in version 2 as it comes in the "COPYING" file of the
+# VirtualBox OSE distribution. VirtualBox OSE is distributed in the
+# hope that it will be useful, but WITHOUT ANY WARRANTY of any kind.
+#
+
+SUB_DEPTH = ../../../..
+include $(KBUILD_PATH)/subheader.kmk
+
+PROGRAMS += VBoxBugReport
+ VBoxBugReport_TEMPLATE = VBOXMAINCLIENTEXE
+# VBoxBugReport_DEFS += \
+ VBOX_WATCHDOG_GLOBAL_PERFCOL VBOX_BUILD_TARGET=\"$(KBUILD_TARGET).$(KBUILD_TARGET_ARCH)\"
+ VBoxBugReport_DEFS.win = _WIN32_WINNT=0x0501 PSAPI_VERSION=1
+ VBoxBugReport_LIBS.win = psapi.lib
+ VBoxBugReport_SOURCES = \
+ VBoxBugReport.cpp
+ VBoxBugReport_SOURCES.win = \
+ VBoxBugReportWin.cpp
+
+include $(FILE_KBUILD_SUB_FOOTER)
+