summaryrefslogtreecommitdiffstats
path: root/src/VBox/HostServices/GuestControl/Makefile.kmk
diff options
context:
space:
mode:
Diffstat (limited to 'src/VBox/HostServices/GuestControl/Makefile.kmk')
-rw-r--r--src/VBox/HostServices/GuestControl/Makefile.kmk49
1 files changed, 49 insertions, 0 deletions
diff --git a/src/VBox/HostServices/GuestControl/Makefile.kmk b/src/VBox/HostServices/GuestControl/Makefile.kmk
new file mode 100644
index 00000000..f36d6438
--- /dev/null
+++ b/src/VBox/HostServices/GuestControl/Makefile.kmk
@@ -0,0 +1,49 @@
+# $Id: Makefile.kmk $
+## @file
+# Sub-Makefile for the Guest Control Host Service.
+#
+
+#
+# Copyright (C) 2011-2019 Oracle Corporation
+#
+# This file is part of VirtualBox Open Source Edition (OSE), as
+# available from http://www.virtualbox.org. This file is free software;
+# you can redistribute it and/or modify it under the terms of the GNU
+# General Public License (GPL) as published by the Free Software
+# Foundation, in version 2 as it comes in the "COPYING" file of the
+# VirtualBox OSE distribution. VirtualBox OSE is distributed in the
+# hope that it will be useful, but WITHOUT ANY WARRANTY of any kind.
+#
+
+SUB_DEPTH = ../../../..
+include $(KBUILD_PATH)/subheader.kmk
+
+# Include sub-makefile(s).
+include $(PATH_SUB_CURRENT)/testcase/Makefile.kmk
+
+#
+# The guest control service DLL.
+#
+DLLS += VBoxGuestControlSvc
+VBoxGuestControlSvc_TEMPLATE = VBOXR3
+VBoxGuestControlSvc_NAME.os2 = VBoxGCTL
+VBoxGuestControlSvc_DEFS = VBOX_WITH_HGCM
+VBoxGuestControlSvc_INCS = $(PATH_ROOT)/src/VBox/Main/include
+VBoxGuestControlSvc_INCS.win = \
+ $(VBOX_PATH_SDK)
+
+VBoxGuestControlSvc_SOURCES = \
+ VBoxGuestControlSvc.cpp
+
+VBoxGuestControlSvc_SOURCES.win = \
+ VBoxGuestControlSvc.rc
+
+VBoxGuestControlSvc_LIBS = \
+ $(LIB_VMM) \
+ $(LIB_RUNTIME) \
+ $(LIB_REM)
+
+VBoxGuestControlSvc_LDFLAGS.darwin = \
+ -install_name $(VBOX_DYLD_EXECUTABLE_PATH)/VBoxGuestControlSvc.dylib
+
+include $(FILE_KBUILD_SUB_FOOTER)