summaryrefslogtreecommitdiffstats
path: root/src/VBox/Installer/Config.kmk
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--src/VBox/Installer/Config.kmk126
1 files changed, 126 insertions, 0 deletions
diff --git a/src/VBox/Installer/Config.kmk b/src/VBox/Installer/Config.kmk
new file mode 100644
index 00000000..53e6621f
--- /dev/null
+++ b/src/VBox/Installer/Config.kmk
@@ -0,0 +1,126 @@
+# $Id: Config.kmk $
+## @file
+# kBuild Configuration file for the installers
+#
+
+#
+# Copyright (C) 2015-2019 Oracle Corporation
+#
+# This file is part of VirtualBox Open Source Edition (OSE), as
+# available from http://www.virtualbox.org. This file is free software;
+# you can redistribute it and/or modify it under the terms of the GNU
+# General Public License (GPL) as published by the Free Software
+# Foundation, in version 2 as it comes in the "COPYING" file of the
+# VirtualBox OSE distribution. VirtualBox OSE is distributed in the
+# hope that it will be useful, but WITHOUT ANY WARRANTY of any kind.
+#
+
+VBOX_INSTALLER_CONFIG_KMK_INCLUDED = 1
+
+# Include the top-level configure file.
+ifndef VBOX_ROOT_CONFIG_KMK_INCLUDED
+ include $(PATH_ROOT)/Config.kmk
+endif
+
+#
+# Generic stuff.
+#
+VBOX_PATH_INST_COMMON_SRC := $(PATH_ROOT)/src/VBox/Installer/common
+
+
+ifdef VBOX_WITH_PYTHON
+ VBOXINST_SDK_BINDINGS_XPCOM_PYTHON_FILES = \
+ sdk/bindings/xpcom/python/xpcom/__init__.py \
+ sdk/bindings/xpcom/python/xpcom/primitives.py \
+ sdk/bindings/xpcom/python/xpcom/file.py \
+ sdk/bindings/xpcom/python/xpcom/xpcom_consts.py \
+ sdk/bindings/xpcom/python/xpcom/nsError.py \
+ sdk/bindings/xpcom/python/xpcom/xpt.py \
+ sdk/bindings/xpcom/python/xpcom/components.py \
+ sdk/bindings/xpcom/python/xpcom/vboxxpcom.py \
+ sdk/bindings/xpcom/python/xpcom/client/__init__.py \
+ sdk/bindings/xpcom/python/xpcom/server/__init__.py \
+ sdk/bindings/xpcom/python/xpcom/server/enumerator.py \
+ sdk/bindings/xpcom/python/xpcom/server/factory.py \
+ sdk/bindings/xpcom/python/xpcom/server/loader.py \
+ sdk/bindings/xpcom/python/xpcom/server/module.py \
+ sdk/bindings/xpcom/python/xpcom/server/policy.py
+ VBOXINST_SDK_INSTALLER_PYTHON_FILES = \
+ sdk/installer/vboxapisetup.py \
+ sdk/installer/vboxapi/__init__.py \
+ sdk/installer/vboxapi/VirtualBox_constants.py
+endif
+
+
+#
+# List of unattended installation script templates (lives in
+# src/VBox/Main/UnattendedTemplates).
+#
+ifdef VBOX_WITH_UNATTENDED
+ VBOX_UNATTENDED_TEMPLATES := \
+ debian_preseed.cfg \
+ ubuntu_preseed.cfg \
+ fedora_ks.cfg \
+ ol_ks.cfg \
+ rhel3_ks.cfg \
+ rhel4_ks.cfg \
+ rhel5_ks.cfg \
+ redhat67_ks.cfg \
+ win_nt5_unattended.sif \
+ win_nt6_unattended.xml \
+ \
+ debian_postinstall.sh \
+ redhat_postinstall.sh \
+ win_postinstall.cmd
+else
+ VBOX_UNATTENDED_TEMPLATES :=
+endif
+
+
+#
+# DTrace globals.
+#
+ifdef VBOX_WITH_DTRACE
+ ## List of files in the per arch DTrace library directory.
+ VBOXINST_DTRACE_LIB_ARCH_FILES := \
+ vbox-types.d \
+ vbox-arch-types.d \
+ vm.d \
+ cpumctx.d \
+ CPUMInternal.d \
+ x86.d
+ ## List of files in the per arch DTrace testcase directory.
+ VBOXINST_DTRACE_TESTCASE_ARCH_FILES := \
+ vbox-vm-struct-test.d
+ ## List of file in the DTrace scripts directory.
+ VBOXINST_DTRACE_SCRIPTS_FILES :=
+else
+ VBOXINST_DTRACE_LIB_ARCH_FILES :=
+ VBOXINST_DTRACE_TESTCASE_ARCH_FILES :=
+ VBOXINST_DTRACE_SCRIPTS_FILES :=
+endif
+
+
+#
+# Some combined package (CP) globals.
+#
+ifeq ($(KBUILD_TARGET_ARCH),x86)
+ VBOX_CP_THIS_BITS := 32
+ ifdef VBOX_WITH_COMBINED_PACKAGE
+ VBOX_CP_OTHER_ARCH := amd64
+ VBOX_CP_OTHER_BITS := 64
+ else
+ VBOX_CP_OTHER_ARCH = $(error VBOX_CP_OTHER_ARCH used in without VBOX_WITH_COMBINED_PACKAGE set)
+ VBOX_CP_OTHER_BITS = $(error VBOX_CP_OTHER_ARCH used in without VBOX_CP_OTHER_BITS set)
+ endif
+else
+ VBOX_CP_THIS_BITS := 64
+ ifdef VBOX_WITH_COMBINED_PACKAGE
+ VBOX_CP_OTHER_ARCH := x86
+ VBOX_CP_OTHER_BITS := 32
+ else
+ VBOX_CP_OTHER_ARCH = $(error VBOX_CP_OTHER_ARCH used in without VBOX_WITH_COMBINED_PACKAGE set)
+ VBOX_CP_OTHER_BITS = $(error VBOX_CP_OTHER_ARCH used in without VBOX_CP_OTHER_BITS set)
+ endif
+endif
+