summaryrefslogtreecommitdiffstats
path: root/src/VBox/Installer/win/VBoxMergePython.wxi
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--src/VBox/Installer/win/VBoxMergePython.wxi41
1 files changed, 41 insertions, 0 deletions
diff --git a/src/VBox/Installer/win/VBoxMergePython.wxi b/src/VBox/Installer/win/VBoxMergePython.wxi
new file mode 100644
index 00000000..bd1d04ea
--- /dev/null
+++ b/src/VBox/Installer/win/VBoxMergePython.wxi
@@ -0,0 +1,41 @@
+<!--
+ VirtualBox Windows Installation Script (WiX)
+
+ Copyright (C) 2006-2016 Oracle Corporation
+
+ This file is part of VirtualBox Open Source Edition (OSE), as
+ available from http://www.virtualbox.org. This file is free software;
+ you can redistribute it and/or modify it under the terms of the GNU
+ General Public License (GPL) as published by the Free Software
+ Foundation, in version 2 as it comes in the "COPYING" file of the
+ VirtualBox OSE distribution. VirtualBox OSE is distributed in the
+ hope that it will be useful, but WITHOUT ANY WARRANTY of any kind.
+-->
+
+<Include xmlns="http://schemas.microsoft.com/wix/2006/wi"
+ xmlns:difxapp="http://schemas.microsoft.com/wix/DifxAppExtension">
+
+<?if $(env.VBOX_WITH_PYTHON) = "yes" ?>
+ <!-- Python bindings -->
+ <Component Id="cp_VBoxPyInst" Guid="C9A40306-5102-11DE-A7BA-C3C555D89593" Win64="$(var.Property_Win64)">
+ <File Id="file_vboxapisetup.py" Name="vboxapisetup.py"
+ Source="$(env.PATH_OUT)\bin\sdk\installer\vboxapisetup.py"
+ DiskId="$(var.Property_DiskIdCommon)" />
+ </Component>
+ <Directory Id="dir_VBoxPythonSDKVBoxAPI" Name="vboxapi">
+ <Component Id="cp_VBoxPyMod" Guid="DF19CB76-5102-11DE-943B-13C755D89593" Win64="$(var.Property_Win64)">
+ <File Id="file___init__.py" Name="__init__.py"
+ Source="$(env.PATH_OUT)\bin\sdk\installer\vboxapi\__init__.py"
+ DiskId="$(var.Property_DiskIdCommon)" />
+ <File Id="file_VirtualBox_constants.py" Name="VirtualBox_constants.py"
+ Source="$(env.PATH_OUT)\bin\sdk\installer\vboxapi\VirtualBox_constants.py"
+ DiskId="$(var.Property_DiskIdCommon)" />
+ </Component>
+ </Directory>
+<?endif?>
+ <Component Id="cp_VBoxPythonBinding" KeyPath="yes"
+ Guid="293D7E11-78DA-4C31-AEED-AE2FE42F6881" Win64="$(var.Property_Win64)">
+ <Condition>VBOX_PYTHON_IS_INSTALLED</Condition>
+ </Component>
+
+</Include>