Description: Change error messages for vboxdrv failure, according to virtualbox-dkms. Author: Daniel Hahler Index: virtualbox/src/VBox/VMM/VMMR3/VM.cpp =================================================================== --- virtualbox.orig/src/VBox/VMM/VMMR3/VM.cpp +++ virtualbox/src/VBox/VMM/VMMR3/VM.cpp @@ -271,10 +271,8 @@ #ifdef RT_OS_LINUX case VERR_SUPDRV_COMPONENT_NOT_FOUND: - pszError = N_("One of the kernel modules was not successfully loaded. Make sure " - "that no kernel modules from an older version of VirtualBox exist. " - "Then try to recompile and reload the kernel modules by executing " - "'/sbin/vboxconfig' as root"); + pszError = N_("Please install the virtualbox-dkms package " + "and execute 'modprobe vboxdrv' as root"); break; #endif @@ -337,10 +335,8 @@ { case VERR_VM_DRIVER_LOAD_ERROR: #ifdef RT_OS_LINUX - pszError = N_("VirtualBox kernel driver not loaded. The vboxdrv kernel module " - "was either not loaded or /dev/vboxdrv is not set up properly. " - "Re-setup the kernel module by executing " - "'/sbin/vboxconfig' as root"); + pszError = N_("Please install the virtualbox-dkms package " + "and execute 'modprobe vboxdrv' as root"); #else pszError = N_("VirtualBox kernel driver not loaded"); #endif @@ -379,10 +375,8 @@ case VERR_INVALID_HANDLE: /** @todo track down and fix this error. */ case VERR_VM_DRIVER_NOT_INSTALLED: #ifdef RT_OS_LINUX - pszError = N_("VirtualBox kernel driver not installed. The vboxdrv kernel module " - "was either not loaded or /dev/vboxdrv was not created for some " - "reason. Re-setup the kernel module by executing " - "'/sbin/vboxconfig' as root"); + pszError = N_("Please install the virtualbox-dkms package " + "and execute 'modprobe vboxdrv' as root"); #else pszError = N_("VirtualBox kernel driver not installed"); #endif Index: virtualbox/src/VBox/Frontends/VirtualBox/src/main.cpp =================================================================== --- virtualbox.orig/src/VBox/Frontends/VirtualBox/src/main.cpp +++ virtualbox/src/VBox/Frontends/VirtualBox/src/main.cpp @@ -87,9 +87,9 @@ QString g_QStrHintLinuxNoDriver = QApplication::tr( "The VirtualBox Linux kernel driver (vboxdrv) is either not loaded or " - "there is a permission problem with /dev/vboxdrv. Please reinstall the kernel " - "module by executing

" - " '/sbin/vboxconfig'

" + "there is a permission problem with /dev/vboxdrv. Please reinstall virtualbox-dkms " + "package and load the kernel module by executing

" + " 'modprobe vboxdrv'

" "as root." ); @@ -104,7 +104,7 @@ "The VirtualBox kernel modules do not match this version of " "VirtualBox. The installation of VirtualBox was apparently not " "successful. Executing

" - " '/sbin/vboxconfig'

" + " 'modprobe vboxdrv'

" "may correct this. Make sure that you do not mix the " "OSE version and the PUEL version of VirtualBox." );