summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 16:04:21 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 16:04:21 +0000
commit056ab9ba6c4a1cb30e60cc4d84f990c3ef566992 (patch)
treec6da0f229297a4ae410275e099edfd2e6e292109 /debian/rules
parentAdding upstream version 2.14.3. (diff)
downloadansible-core-056ab9ba6c4a1cb30e60cc4d84f990c3ef566992.tar.xz
ansible-core-056ab9ba6c4a1cb30e60cc4d84f990c3ef566992.zip
Adding debian version 2.14.3-1.debian/2.14.3-1debian
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules34
1 files changed, 34 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..0c06b97
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,34 @@
+#!/usr/bin/make -f
+
+DOPACKAGES = $(shell dh_listpackages)
+export PYBUILD_DESTDIR=debian/tmp
+
+# Make it easier to build on machines with ansible << 2.10 installed.
+export ANSIBLE_SKIP_CONFLICT_CHECK=1
+
+# tmpdir is needed during docs build, as ~ isn't writeable in sbuild
+export ANSIBLE_LOCAL_TEMP=tmp/
+
+%:
+# dh $@ --with python3,sphinxdoc --buildsystem=pybuild
+ dh $@ --with python3 --buildsystem=pybuild
+
+override_dh_clean:
+ dh_clean \
+ --exclude=test/units/inventory_test_data/group_vars/noparse/all.yml~ \
+ --exclude=test/integration/targets/collections/collection_root_user/ansible_collections/testns/testcoll/plugins/modules/uses_leaf_mu_flat_import.bak
+
+execute_after_dh_auto_build:
+ # manpage documentation
+ $(MAKE) docs
+ifneq (,$(filter ansible-doc,$(DOPACKAGES)))
+ # html documentation
+ $(MAKE) webdocs
+endif
+
+override_dh_auto_test:
+ # For now, disable the tests
+ #make tests-nonet
+
+override_dh_python3:
+ dh_python3 --shebang=/usr/bin/python3