summaryrefslogtreecommitdiffstats
path: root/.config
diff options
context:
space:
mode:
Diffstat (limited to '.config')
-rw-r--r--.config/ansible-lint.spec73
-rw-r--r--.config/dictionary.txt390
-rw-r--r--.config/requirements-docs.txt12
-rw-r--r--.config/requirements-lock.txt39
-rw-r--r--.config/requirements-test.txt13
-rw-r--r--.config/requirements.in15
-rw-r--r--.config/requirements.txt101
7 files changed, 643 insertions, 0 deletions
diff --git a/.config/ansible-lint.spec b/.config/ansible-lint.spec
new file mode 100644
index 0000000..22a46f9
--- /dev/null
+++ b/.config/ansible-lint.spec
@@ -0,0 +1,73 @@
+# spell-checker:ignore bcond pkgversion buildrequires autosetup PYTHONPATH noarch buildroot bindir sitelib numprocesses clib
+# All tests require Internet access
+# to test in mock use: --enable-network --with check
+# to test in a privileged environment use:
+# --with check --with privileged_tests
+%bcond_with check
+%bcond_with privileged_tests
+
+Name: ansible-lint
+Version: VERSION_PLACEHOLDER
+Release: 1%{?dist}
+Summary: Ansible-lint checks ansible content for common mistakes
+
+License: GPL-3.0-or-later AND MIT
+URL: https://github.com/ansible/ansible-lint
+Source0: %{pypi_source}
+
+BuildArch: noarch
+
+BuildRequires: python%{python3_pkgversion}-devel
+%if %{with check}
+# These are required for tests:
+BuildRequires: python%{python3_pkgversion}-pytest
+BuildRequires: python%{python3_pkgversion}-pytest-xdist
+BuildRequires: python%{python3_pkgversion}-libselinux
+BuildRequires: git-core
+%endif
+Requires: git-core
+
+
+%description
+Ansible-lint checks ansible content for practices and behaviors that could
+potentially be improved.
+
+%prep
+%autosetup
+
+
+%generate_buildrequires
+%pyproject_buildrequires
+
+
+%build
+%pyproject_wheel
+
+
+%install
+%pyproject_install
+%pyproject_save_files ansiblelint
+
+
+%check
+# Don't try to import tests that import pytest which isn't available at runtime
+%pyproject_check_import -e 'ansiblelint.testing*' -e 'ansiblelint.rules.conftest'
+%if %{with check}
+%pytest \
+ -v \
+ --disable-pytest-warnings \
+ --numprocesses=auto \
+%if %{with privileged_tests}
+ tests
+%else
+ tests/unit
+%endif
+%endif
+
+
+%files -f %{pyproject_files}
+%{_bindir}/ansible-lint
+%license COPYING docs/licenses/LICENSE.mit.txt
+%doc docs/ README.md
+
+%changelog
diff --git a/.config/dictionary.txt b/.config/dictionary.txt
new file mode 100644
index 0000000..3a2184b
--- /dev/null
+++ b/.config/dictionary.txt
@@ -0,0 +1,390 @@
+Adrián
+Autobuild
+CLICOLOR
+CODENOTIFY
+CODEOWNERS
+CTYPE
+Cacqueray
+Chamoulaud
+DISTRO
+DOTGLOB
+ENVVAR
+EPIPE # linux
+Fimport
+Jython
+MYTAG
+PYTHONBREAKPOINT
+PYTHONIOENCODING
+PYTHONPYCACHEPREFIX
+REQPASS
+RULEDIRS
+RUNLEVEL
+Renderable
+Representer
+SIGUSR1
+SRCROOT
+Sbarnea
+Sorin
+Sshell
+TOXENV
+TYPECHECK
+Taskfiles
+Tsukinowa
+Tóth
+WSLENV
+aarch64
+abspath
+addoption
+addopts
+ansiblelint
+apidoc
+apport
+argparsing
+argspecs
+arxcruz
+auditd
+autobuild
+autoclass
+autodetected
+autodiscovery
+autodoc
+autofix
+autorefs
+autoupdate
+awcrosby
+backports
+backticks
+bdist
+becomeuserabove
+bindep
+blockincludes
+blockinfile
+bools
+boto
+bracketsmatchtest
+bracketsmatchtestfile
+buildinfo
+buildset
+builtins
+cachier
+capfd
+caplog
+capsys
+cffi
+chdir
+chgrp
+chkconfig
+chunksize
+clib
+codeclimate
+codecov
+codenotify
+codeql
+codespell
+colorama
+colsystem
+commandline
+commitlint
+commonmark
+compat
+conftest
+coveragerc
+cpus
+cpuset
+createfile
+darglint
+dataclasses
+dbservers
+deannotate
+debops
+decryptable
+delenv
+dellemc
+denormalize
+deps
+devel
+dharmabumstead
+dirhtml
+dists
+distutils
+doas
+docstrings
+doctest
+doctrees
+docutils
+dotconfig
+dotslash
+drybjed
+dzdo
+ematcher
+ematchtestfile
+envrc
+execnet
+extlinks
+facelessuser
+facter
+fakerole
+fileglob
+filelock
+filesspot
+filetree
+fips
+firewalld
+fontawesome
+formatstr
+formetting
+formsyntax
+fqcn
+fqrn
+fulltoc
+fullwidth
+gecos
+geerlingguy
+getmatches
+globbing
+globmatch
+groupname
+hostkey
+hostnames
+hostvars
+htmldir
+htmlproofer
+htpasswd
+hwchksum
+hwcksum
+idempotency
+importlib
+iniconfig
+inlinehilite
+insertafter
+ipwrap
+isclass
+iscsi
+isdir
+isdisjoint
+iskeyword
+isort
+jsonfile
+jsonschema
+junitxml
+keepends
+keyserver
+konstruktoid
+kubernetes
+kubevirt
+languageservice
+letsencrypt
+levelname
+libbzip
+libera
+libyaml
+lineinfile
+linenums
+linkcheck
+lintable
+lintables
+literalinclude
+localectl
+machinectl
+magiclink
+markdownlint
+matchdir
+matcherror
+matchlines
+matchtask
+matchtasks
+matchvar
+matchyaml
+maxdepth
+minversion
+mkdir
+mkdocs
+mkdocstrings
+mkdtemp
+mockings
+mockreturn
+modifyitems
+modindex
+moduleauthor
+mypy
+myrole
+namedtempfile
+nestedincludes
+netcommon
+nilashishc
+nitpicky
+nocolor
+nodeps
+noexist
+nomatches
+nomatchestest
+noqa
+norole
+nostderr
+notest
+nxos
+octal
+octals
+opensearch
+openshift
+outdir
+outlen
+pageview
+parseable
+pathex
+pathlib
+pathspec
+pbrun
+pfexec
+pickleable
+pipdeptree
+pipefail
+piptools
+pipx
+pkgcache # linux
+pkgs
+placefolder
+pluggy
+pluginmanager
+podman
+prerun
+prettierignore
+programoutput
+psutil
+pyargs
+pycache
+pycharm
+pyenv
+pygments
+pylint
+pylintrc
+pymdown
+pymdownx
+pypa
+pyparsing
+pypi
+pyproject
+pyproject.toml
+pypy
+pyright
+pytest
+pyupgrade
+pyyaml
+redirections
+reexec
+regexes
+releasenotes
+relpath
+reportversion
+representer
+reqs
+returncode
+rmtree
+robertdebock
+rolepath
+roundtrip
+ruamel
+rulebook
+rulebooks
+ruledirs
+rulesdir
+rulesdirs
+ruleset
+runas
+sarif
+scalarint
+schemafile
+sdist
+sdists
+sectionauthor
+seealso
+setenv
+setuptools
+shortdesc
+showlocals
+shutil
+signoff
+simpletask
+skippable
+skiptasks
+skiputils
+slaveinput
+sortfunc
+sourcegraph
+srpm
+ssbarnea
+stylesheet
+subdir
+subelements
+subresults
+subschema
+subschemas
+substrs
+subtest
+superfences
+supervisorctl
+synchronize
+sysvinit
+taskfile
+taskhandler
+taskimports
+taskincludes
+taskshandlers
+templatevars
+templating
+testinfra
+testmon
+testns
+testpath
+testpaths
+testproject
+testpypi
+testrun
+timesyncd
+tmpfs
+toctree
+toidentifier
+tomli
+toolset
+tripleo
+typehint
+typehints
+ulimits
+uncook
+ungrouped
+unignored
+unimported
+unindented
+uninstallation
+unjinja
+unlex
+unnormalized
+unskippable
+unspaced
+unsubscriptable
+untemplated
+userbase
+uwsgi
+validable
+varname
+varnotset
+varset
+varsfile
+varstring
+varunset
+venv
+viewcode
+virtnet
+virtualenv
+virtualenvs
+wcmatch
+webserver
+webservers
+willthames
+workdir
+worktree
+xdist
+xfail
+xunit
+yatesr
+zuul
diff --git a/.config/requirements-docs.txt b/.config/requirements-docs.txt
new file mode 100644
index 0000000..520919c
--- /dev/null
+++ b/.config/requirements-docs.txt
@@ -0,0 +1,12 @@
+cairosvg
+markdown-exec>=1.0.0
+mkdocs-gen-files>=0.4.0
+mkdocs-htmlproofer-plugin
+mkdocs-material-extensions>=1.1.1
+mkdocs-material>=9.0.6
+mkdocs>=1.4.2
+mkdocstrings-python>=0.8.3
+mkdocstrings>=0.20.0
+pillow
+pipdeptree>=2.3.3
+pymdown-extensions>=9.9.2
diff --git a/.config/requirements-lock.txt b/.config/requirements-lock.txt
new file mode 100644
index 0000000..4d06524
--- /dev/null
+++ b/.config/requirements-lock.txt
@@ -0,0 +1,39 @@
+#
+# This file is autogenerated by pip-compile with Python 3.9
+# by the following command:
+#
+# pip-compile --no-annotate --output-file=.config/requirements-lock.txt --resolver=backtracking --strip-extras --unsafe-package=ruamel-yaml-clib pyproject.toml
+#
+ansible-core==2.14.2 ; python_version >= "3.9"
+attrs==22.2.0
+black==22.12.0
+bracex==2.3.post1
+cffi==1.15.1
+click==8.1.3
+cryptography==39.0.1
+filelock==3.9.0
+jinja2==3.1.2
+jsonschema==4.17.3
+markdown-it-py==2.1.0
+markupsafe==2.1.1
+mdurl==0.1.2
+mypy-extensions==0.4.3
+packaging==22.0
+pathspec==0.10.3
+platformdirs==2.6.2
+pycparser==2.21
+pygments==2.13.0
+pyrsistent==0.19.3
+pyyaml==6.0
+resolvelib==0.8.1
+rich==13.2.0
+ruamel-yaml==0.17.21
+setuptools==65.6.3
+subprocess-tee==0.4.1
+tomli==2.0.1
+typing-extensions==4.4.0
+wcmatch==8.4.1
+yamllint==1.28.0
+
+# The following packages are considered to be unsafe in a requirements file:
+# ruamel-yaml-clib
diff --git a/.config/requirements-test.txt b/.config/requirements-test.txt
new file mode 100644
index 0000000..a89d450
--- /dev/null
+++ b/.config/requirements-test.txt
@@ -0,0 +1,13 @@
+black # IDE support
+coverage-enable-subprocess # see https://github.com/nedbat/coveragepy/issues/1341#issuecomment-1228942657
+coverage[toml] >= 6.4.4
+flake8 # IDE support
+flake8-future-annotations # IDE support
+mypy # IDE support
+psutil # soft-dep of pytest-xdist
+pylint # IDE support
+pytest >= 7.2.0
+pytest-mock
+pytest-plus >= 0.2 # for PYTEST_REQPASS
+pytest-xdist >= 2.1.0
+types-pyyaml # IDE support
diff --git a/.config/requirements.in b/.config/requirements.in
new file mode 100644
index 0000000..1f34a8b
--- /dev/null
+++ b/.config/requirements.in
@@ -0,0 +1,15 @@
+# Special order section for helping pip:
+will-not-work-on-windows-try-from-wsl-instead; platform_system=='Windows'
+ansible-core>=2.12.0,<2.14.0; python_version<'3.9' # GPLv3
+ansible-core>=2.12.0; python_version>='3.9' # GPLv3
+# alphabetically sorted:
+black>=22.8.0 # MIT
+filelock>=3.3.0 # The Unlicense
+jsonschema>=4.10.0 # MIT, version needed for improved errors
+packaging>=21.3 # Apache-2.0,BSD-2-Clause
+pyyaml>=5.4.1 # MIT (centos 9 has 5.3.1)
+rich>=12.0.0 # MIT
+ruamel.yaml>=0.17.21,<0.18 # MIT, next version is planned to have breaking changes
+subprocess-tee>=0.4.1 # MIT, used by ansible-compat
+yamllint >= 1.26.3 # GPLv3
+wcmatch>=8.1.2 # MIT
diff --git a/.config/requirements.txt b/.config/requirements.txt
new file mode 100644
index 0000000..7b85efe
--- /dev/null
+++ b/.config/requirements.txt
@@ -0,0 +1,101 @@
+#
+# This file is autogenerated by pip-compile with Python 3.9
+# by the following command:
+#
+# pip-compile --extra=docs --extra=test --no-annotate --output-file=.config/requirements.txt --resolver=backtracking --strip-extras --unsafe-package=ruamel-yaml-clib pyproject.toml
+#
+ansible-core==2.14.2 ; python_version >= "3.9"
+astroid==2.14.2
+attrs==22.2.0
+beautifulsoup4==4.11.2
+black==23.1.0
+bracex==2.3.post1
+cairocffi==1.4.0
+cairosvg==2.6.0
+certifi==2022.12.7
+cffi==1.15.1
+charset-normalizer==3.0.1
+click==8.1.3
+colorama==0.4.6
+coverage==7.1.0
+coverage-enable-subprocess==1.0
+cryptography==39.0.1
+cssselect2==0.7.0
+defusedxml==0.7.1
+dill==0.3.6
+exceptiongroup==1.1.0
+execnet==1.9.0
+filelock==3.9.0
+flake8==6.0.0
+flake8-future-annotations==1.1.0
+ghp-import==2.1.0
+griffe==0.25.4
+idna==3.4
+importlib-metadata==6.0.0
+iniconfig==2.0.0
+isort==5.12.0
+jinja2==3.1.2
+jsonschema==4.17.3
+lazy-object-proxy==1.9.0
+markdown==3.3.7
+markdown-exec==1.2.0
+markdown-it-py==2.1.0
+markupsafe==2.1.2
+mccabe==0.7.0
+mdurl==0.1.2
+mergedeep==1.3.4
+mkdocs==1.4.2
+mkdocs-autorefs==0.4.1
+mkdocs-gen-files==0.4.0
+mkdocs-htmlproofer-plugin==0.10.2
+mkdocs-material==9.0.12
+mkdocs-material-extensions==1.1.1
+mkdocstrings==0.20.0
+mkdocstrings-python==0.8.3
+mypy==1.0.0
+mypy-extensions==1.0.0
+packaging==23.0
+pathspec==0.11.0
+pillow==9.4.0
+pipdeptree==2.3.3
+platformdirs==3.0.0
+pluggy==1.0.0
+psutil==5.9.4
+pycodestyle==2.10.0
+pycparser==2.21
+pyflakes==3.0.1
+pygments==2.14.0
+pylint==2.16.1
+pymdown-extensions==9.9.2
+pyrsistent==0.19.3
+pytest==7.2.1
+pytest-mock==3.10.0
+pytest-plus==0.4.0
+pytest-xdist==3.2.0
+python-dateutil==2.8.2
+pyyaml==6.0
+pyyaml-env-tag==0.1
+regex==2022.10.31
+requests==2.28.2
+resolvelib==0.8.1
+rich==13.3.1
+ruamel-yaml==0.17.21
+setuptools==67.2.0
+six==1.16.0
+soupsieve==2.3.2.post1
+subprocess-tee==0.4.1
+tinycss2==1.2.1
+tomli==2.0.1
+tomlkit==0.11.6
+types-pyyaml==6.0.12.6
+typing-extensions==4.4.0
+urllib3==1.26.14
+watchdog==2.2.1
+wcmatch==8.4.1
+webencodings==0.5.1
+wrapt==1.14.1
+yamllint==1.29.0
+zipp==3.13.0
+
+# The following packages are considered to be unsafe in a requirements file:
+# ruamel-yaml-clib