summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to '')
-rwxr-xr-xdebian/rules33
1 files changed, 33 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 00000000..af273652
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,33 @@
+#!/usr/bin/make -f
+
+# Make it easier to build one machines with ansible << 2.10 installed.
+export ANSIBLE_SKIP_CONFLICT_CHECK=1
+
+%:
+ dh $@ --with python3 --buildsystem=pybuild
+
+override_dh_clean:
+ dh_clean \
+ -X.bak \
+ -X.md~ \
+ -X.j2~ \
+ -X.py~ \
+ -X.txt~ \
+ -X.txt.orig \
+ -X.un~ \
+ -X.yaml~ \
+ -X.yml~
+
+override_dh_auto_test:
+ # For now, disable the tests
+ #make tests-nonet
+
+override_dh_python3:
+ dh_python3 --shebang=/usr/bin/python3
+
+execute_after_dh_auto_install:
+ find debian/ansible/ -depth -name '.git*' -exec rm -r {} +
+ find debian/ansible/ -depth -name '.*' -exec rm -r {} +
+ find debian/ansible/ -name '*~' -delete
+ find debian/ansible/ -name '*.bak' -delete
+ find debian/ansible/ -name '*.orig' -delete