summaryrefslogtreecommitdiffstats
path: root/debian/patches/dont_override_external_buildflags
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/dont_override_external_buildflags')
-rw-r--r--debian/patches/dont_override_external_buildflags19
1 files changed, 19 insertions, 0 deletions
diff --git a/debian/patches/dont_override_external_buildflags b/debian/patches/dont_override_external_buildflags
new file mode 100644
index 0000000..0d02577
--- /dev/null
+++ b/debian/patches/dont_override_external_buildflags
@@ -0,0 +1,19 @@
+# Don't force apr-using projects to use the compile flags used during
+# apr's compilation.
+--- apr.orig/build/apr_rules.mk.in
++++ apr/build/apr_rules.mk.in
+@@ -42,10 +42,10 @@ LIBTOOL=@LIBTOOL@
+ # compilation and linking flags that are supposed to be set only by the user.
+ # configure adds to them for tests, but we restore them at the end.
+ #
+-CFLAGS=@CFLAGS@
+-CPPFLAGS=@CPPFLAGS@
+-LDFLAGS=@LDFLAGS@
+-LIBS=@LIBS@
++CFLAGS?=@CFLAGS@
++CPPFLAGS?=@CPPFLAGS@
++LDFLAGS?=@LDFLAGS@
++LIBS?=@LIBS@
+ DEFS=@DEFS@
+
+ # anything added to the standard flags by configure is moved to EXTRA_*