summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 16:27:44 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 16:27:44 +0000
commit32a000d14361b76a22f0db8d22553d7fa2a1b40c (patch)
treeb3b4e83e7f01625e58f3b6c256d47c01e90e7238 /debian/rules
parentAdding upstream version 2.2.0. (diff)
downloadasciinema-32a000d14361b76a22f0db8d22553d7fa2a1b40c.tar.xz
asciinema-32a000d14361b76a22f0db8d22553d7fa2a1b40c.zip
Adding debian version 2.2.0-1.debian/2.2.0-1debian
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules21
1 files changed, 21 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..e55e84c
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,21 @@
+#!/usr/bin/make -f
+
+include /usr/share/dpkg/pkg-info.mk
+
+%:
+ dh $@ --buildsystem=pybuild --verbose --with python3
+
+override_dh_auto_test:
+ifeq (,$(filter nocheck,$(DEB_BUILD_OPTIONS)))
+ $(MAKE) test.unit
+endif
+
+clean:
+ dh_clean asciinema.egg-info/ asciinema/commands/__pycache__/ tests/__pycache__/ asciinema/__pycache__/ .pybuild/ pybuild/ .mypy_cache/
+
+# taken from openstack-pkg-tools
+gen-orig-gz:
+ git tag -v v$(DEB_VERSION_UPSTREAM)
+ if [ ! -f ../$(DEB_SOURCE)_$(DEB_VERSION_UPSTREAM).orig.tar.gz ] ; then \
+ git archive --prefix=$(DEB_SOURCE)-$(DEB_VERSION_UPSTREAM)/ v$(GIT_TAG) | gzip >../$(DEB_SOURCE)_$(DEB_VERSION_UPSTREAM).orig.tar.gz ; \
+ fi