summaryrefslogtreecommitdiffstats
path: root/.editorconfig
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 09:14:42 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 09:14:42 +0000
commit0bc58b66a4850cdb8458a86c3d9a2fc81de82aa3 (patch)
treeea0fe36eb5e6f40e0a1f765d44c4b0c0b2bfb089 /.editorconfig
parentInitial commit. (diff)
downloadbash-completion-upstream/1%2.11.tar.xz
bash-completion-upstream/1%2.11.zip
Adding upstream version 1:2.11.upstream/1%2.11upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to '')
-rw-r--r--.editorconfig18
1 files changed, 18 insertions, 0 deletions
diff --git a/.editorconfig b/.editorconfig
new file mode 100644
index 0000000..85032d1
--- /dev/null
+++ b/.editorconfig
@@ -0,0 +1,18 @@
+[*]
+indent_style = space
+indent_size = 4
+tab_width = 8
+end_of_line = lf
+charset = utf-8
+trim_trailing_whitespace = true
+insert_final_newline = true
+max_line_length = 79
+# for shfmt
+function_next_line = true
+switch_case_indent = true
+
+[Makefile.am]
+indent_style = tab
+
+[*.{yml,yaml}]
+indent_size = 2