summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2022-02-02 18:15:49 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2022-02-02 18:18:29 +0000
commitea3530f9a5803cc245574f9828d158baeb955303 (patch)
treead9af530b303d5d48b5b9c3ec1cbb50d929d8dfb
parentAdding debian version 1.15.1-3. (diff)
downloadcppunit-debian.tar.xz
cppunit-debian.zip
Adding debian version 1.15.1-4.debian/1.15.1-4debian
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
-rw-r--r--debian/changelog8
-rw-r--r--debian/control2
-rw-r--r--debian/patches/run-tests-in-deterministic-order.diff25
-rw-r--r--debian/patches/series1
4 files changed, 35 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 41a0387..456ca2d 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,11 @@
+cppunit (1.15.1-4) unstable; urgency=medium
+
+ * debian/patches/patches/run-tests-in-deterministic-order.diff: apply
+ patch from LOs copy - as name says. Also fixes LOs tests with
+ --enable-lto
+
+ -- Rene Engelhard <rene@debian.org> Thu, 21 Oct 2021 21:44:05 +0200
+
cppunit (1.15.1-3) unstable; urgency=medium
* Team upload.
diff --git a/debian/control b/debian/control
index e69d78e..c3ac435 100644
--- a/debian/control
+++ b/debian/control
@@ -3,7 +3,7 @@ Homepage: https://www.freedesktop.org/wiki/Software/cppunit
Section: devel
Priority: optional
Maintainer: Debian LibreOffice Maintainers <debian-openoffice@lists.debian.org>
-Uploaders: Rene Engelhard <rene@debian.org>, Steve M. Robbins <smr@debian.org>
+Uploaders: Rene Engelhard <rene@debian.org>
Build-Depends: debhelper-compat (= 13)
Build-Depends-Indep: doxygen, graphviz
Standards-Version: 4.6.0
diff --git a/debian/patches/run-tests-in-deterministic-order.diff b/debian/patches/run-tests-in-deterministic-order.diff
new file mode 100644
index 0000000..fa4b9de
--- /dev/null
+++ b/debian/patches/run-tests-in-deterministic-order.diff
@@ -0,0 +1,25 @@
+--- a/src/cppunit/TestFactoryRegistry.cpp
++++ b/src/cppunit/TestFactoryRegistry.cpp
+@@ -143,13 +143,21 @@
+ void
+ TestFactoryRegistry::addTestToSuite( TestSuite *suite )
+ {
++ std::multimap<std::string, Test *> sorted;
+ for ( Factories::iterator it = m_factories.begin();
+ it != m_factories.end();
+ ++it )
+ {
+ TestFactory *factory = *it;
+- suite->addTest( factory->makeTest() );
++ Test *test = factory->makeTest();
++ sorted.insert({test->getName(), test});
+ }
++ // In the unlikely case of multiple Tests with identical names, those will
++ // still be added in random order:
++ for (auto const &i: sorted)
++ {
++ suite->addTest( i.second );
++ }
+ }
+
+
diff --git a/debian/patches/series b/debian/patches/series
new file mode 100644
index 0000000..ac0befb
--- /dev/null
+++ b/debian/patches/series
@@ -0,0 +1 @@
+run-tests-in-deterministic-order.diff