summaryrefslogtreecommitdiffstats
path: root/dm-packaging/debian/rules
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 09:19:41 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 09:19:41 +0000
commita27c8b00ebf173659f22f53ce65679e94e7dfb1b (patch)
tree02c68ec259348b63c6328896aa73265eb7b3d730 /dm-packaging/debian/rules
parentInitial commit. (diff)
downloaddebian-keyring-a27c8b00ebf173659f22f53ce65679e94e7dfb1b.tar.xz
debian-keyring-a27c8b00ebf173659f22f53ce65679e94e7dfb1b.zip
Adding upstream version 2022.12.24.upstream/2022.12.24upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'dm-packaging/debian/rules')
-rwxr-xr-xdm-packaging/debian/rules27
1 files changed, 27 insertions, 0 deletions
diff --git a/dm-packaging/debian/rules b/dm-packaging/debian/rules
new file mode 100755
index 0000000..6e1c367
--- /dev/null
+++ b/dm-packaging/debian/rules
@@ -0,0 +1,27 @@
+#!/usr/bin/make -f
+%:
+ dh $@
+
+build:
+ # Disable anything needing the network when building.
+ # This won't fully exersise the test suite; some tests need to be
+ # online to download the Debian keyring, for example. Recommend
+ # running make test by hand from time to time to fully test it.
+ # (Note that the full test suite is run by the review script before
+ # changesets are added.)
+ ONLINE=n dh build
+
+VER = $(shell dpkg-parsechangelog | sed -ne 's/^Version: //p')
+
+binary-indep: build
+ dh binary-indep --until dh_prep
+ dh_installdocs README TODO
+ dh_installexamples sample.changeset
+ dh_install debian-maintainers.gpg usr/share/keyrings/
+ dh binary-indep --remaining
+
+ # byhand file for dak
+ cp debian-maintainers.gpg ../debian-maintainers_$(VER)_all.gpg
+ dpkg-distaddfile debian-maintainers_$(VER)_all.gpg raw-keyring -
+
+binary: binary-indep binary-arch