summaryrefslogtreecommitdiffstats
path: root/tests/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 16:08:06 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 16:08:06 +0000
commitba6d96469df143b52295f8e79da648bf8a597407 (patch)
tree5ea0c3374f5c53209ad02008dcdddfc8ccae92e5 /tests/Makefile
parentInitial commit. (diff)
downloaddh-python-ba6d96469df143b52295f8e79da648bf8a597407.tar.xz
dh-python-ba6d96469df143b52295f8e79da648bf8a597407.zip
Adding upstream version 5.20230130+deb12u1.upstream/5.20230130+deb12u1upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to '')
-rw-r--r--tests/Makefile20
1 files changed, 20 insertions, 0 deletions
diff --git a/tests/Makefile b/tests/Makefile
new file mode 100644
index 0000000..55f0c9e
--- /dev/null
+++ b/tests/Makefile
@@ -0,0 +1,20 @@
+#!/usr/bin/make -f
+
+# enable or disable tests here:
+#TESTS := test301 test302 test303 test304 test305 test306 testpb01 testpb02 testpb03 testpb04 testpb05 testpb06 testpb07 testa01 testa02
+TESTS := test301 test302 test303 test304 test305 test306
+
+all: $(TESTS)
+
+test%:
+ make -C t$* run
+ make -C t$* check
+
+clean-test%:
+ make -C t$* clean
+
+clean: $(TESTS:%=clean-%)
+ rm -f *\.dsc *\.tar\.gz *\.build *\.changes *\.deb *\.buildinfo
+ @find . -prune -name '*.egg-info' -exec rm -rf '{}' ';' || true
+
+.PHONY: clean