summaryrefslogtreecommitdiffstats
path: root/tests/t301/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 16:08:06 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 16:08:06 +0000
commitba6d96469df143b52295f8e79da648bf8a597407 (patch)
tree5ea0c3374f5c53209ad02008dcdddfc8ccae92e5 /tests/t301/Makefile
parentInitial commit. (diff)
downloaddh-python-ba6d96469df143b52295f8e79da648bf8a597407.tar.xz
dh-python-ba6d96469df143b52295f8e79da648bf8a597407.zip
Adding upstream version 5.20230130+deb12u1.upstream/5.20230130+deb12u1upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'tests/t301/Makefile')
-rw-r--r--tests/t301/Makefile15
1 files changed, 15 insertions, 0 deletions
diff --git a/tests/t301/Makefile b/tests/t301/Makefile
new file mode 100644
index 0000000..4be460f
--- /dev/null
+++ b/tests/t301/Makefile
@@ -0,0 +1,15 @@
+#!/usr/bin/make -f
+include ../common.mk
+
+check:
+ grep -qe "Depends: .*python3\(:any\)\? (<< 3.9)" debian/python3-foo/DEBIAN/control
+ grep -q "Recommends: .*python3-mako" debian/python3-foo/DEBIAN/control
+ test -f debian/python3-foo/usr/lib/python3/dist-packages/foo/__init__.py
+ test ! -f debian/python3-foo/usr/lib/python3/dist-packages/foo/spam.py
+ grep -q 'py3compile -p python3-foo -V 3\.1-3\.9' debian/python3-foo/DEBIAN/postinst
+ grep -q 'pypy3compile -p python3-foo -V 3\.1-3\.9' debian/python3-foo/DEBIAN/postinst
+ grep -q 'py3clean -p python3-foo\s*$$' debian/python3-foo/DEBIAN/prerm
+
+clean:
+ ./debian/rules clean
+ rm -rf lib/Foo.egg-info