summaryrefslogtreecommitdiffstats
path: root/tests/t304/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 16:08:06 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 16:08:06 +0000
commitba6d96469df143b52295f8e79da648bf8a597407 (patch)
tree5ea0c3374f5c53209ad02008dcdddfc8ccae92e5 /tests/t304/Makefile
parentInitial commit. (diff)
downloaddh-python-ba6d96469df143b52295f8e79da648bf8a597407.tar.xz
dh-python-ba6d96469df143b52295f8e79da648bf8a597407.zip
Adding upstream version 5.20230130+deb12u1.upstream/5.20230130+deb12u1upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'tests/t304/Makefile')
-rw-r--r--tests/t304/Makefile23
1 files changed, 23 insertions, 0 deletions
diff --git a/tests/t304/Makefile b/tests/t304/Makefile
new file mode 100644
index 0000000..d69cdc9
--- /dev/null
+++ b/tests/t304/Makefile
@@ -0,0 +1,23 @@
+#!/usr/bin/make -f
+
+include ../common.mk
+clean: clean-common
+
+check:
+ # python3.2 hardcoded via `dh_python3 --shebang ...python3.2`
+ grep -q '#! /usr/bin/python3.2 -OO' debian/foo/usr/share/baz32/baz.py
+ # python3.4 hardcoded via shebang
+ grep -q '/usr/share/foo \-V 3.4' debian/foo/DEBIAN/postinst
+ # /env removed from shebang
+ grep -q '#! /usr/bin/python3' debian/foo/usr/share/bar/bar.py
+ # /local removed from shebang
+ grep -q '#! /usr/bin/python3' debian/foo/usr/share/foo/baz.py
+ grep -q '#! /usr/bin/python3.4' debian/foo/usr/share/foo/foo.py
+ # make sure /usr/share/doc/ is ignored
+ grep -q -v "py3compile -p foo /usr/share/doc"\
+ debian/foo/DEBIAN/postinst
+ # -X made it into the postinst
+ grep -qF "/usr/share/bar -X 'spam.py'" debian/foo/DEBIAN/postinst
+ # Check argument parsing order
+ grep -q '#! /usr/bin/python3-dbg' debian/overrides/usr/share/overrides1/foo.py
+ grep -q '#! /usr/bin/python3-dbg' debian/overrides/usr/share/overrides2/foo.py