summaryrefslogtreecommitdiffstats
path: root/tests/t304/debian/rules
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 16:08:06 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 16:08:06 +0000
commitba6d96469df143b52295f8e79da648bf8a597407 (patch)
tree5ea0c3374f5c53209ad02008dcdddfc8ccae92e5 /tests/t304/debian/rules
parentInitial commit. (diff)
downloaddh-python-ba6d96469df143b52295f8e79da648bf8a597407.tar.xz
dh-python-ba6d96469df143b52295f8e79da648bf8a597407.zip
Adding upstream version 5.20230130+deb12u1.upstream/5.20230130+deb12u1upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'tests/t304/debian/rules')
-rwxr-xr-xtests/t304/debian/rules26
1 files changed, 26 insertions, 0 deletions
diff --git a/tests/t304/debian/rules b/tests/t304/debian/rules
new file mode 100755
index 0000000..5de6e3d
--- /dev/null
+++ b/tests/t304/debian/rules
@@ -0,0 +1,26 @@
+#!/usr/bin/make -f
+%:
+ dh $@ --buildsystem=python_distutils
+
+override_dh_auto_build:
+override_dh_auto_install:
+
+override_dh_install:
+ dh_install
+ DH_VERBOSE=1 ../../dh_python3 -p foo
+ DH_VERBOSE=1 ../../dh_python3 -p foo /usr/share/bar -X spam.py
+ DH_VERBOSE=1 ../../dh_python3 -p foo /usr/share/baz32 --shebang '/usr/bin/python3.2 -OO'
+
+ # Argument priority: -O > regular args > DH_OPTIONS
+ DH_VERBOSE=1 DH_OPTIONS=--shebang=/usr/bin/python3.0 \
+ ../../dh_python3 -p overrides \
+ --shebang=/usr/bin/python3-dbg \
+ /usr/share/overrides1
+ DH_VERBOSE=1 ../../dh_python3 -p overrides \
+ --shebang=/usr/bin/python3.0 \
+ -O=--shebang=/usr/bin/python3-dbg \
+ -O=--foo=bar \
+ /usr/share/overrides2
+
+clean:
+ dh_clean