summaryrefslogtreecommitdiffstats
path: root/tests/t306/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 16:08:06 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 16:08:06 +0000
commitba6d96469df143b52295f8e79da648bf8a597407 (patch)
tree5ea0c3374f5c53209ad02008dcdddfc8ccae92e5 /tests/t306/Makefile
parentInitial commit. (diff)
downloaddh-python-ba6d96469df143b52295f8e79da648bf8a597407.tar.xz
dh-python-ba6d96469df143b52295f8e79da648bf8a597407.zip
Adding upstream version 5.20230130+deb12u1.upstream/5.20230130+deb12u1upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'tests/t306/Makefile')
-rw-r--r--tests/t306/Makefile17
1 files changed, 17 insertions, 0 deletions
diff --git a/tests/t306/Makefile b/tests/t306/Makefile
new file mode 100644
index 0000000..9dbf8c4
--- /dev/null
+++ b/tests/t306/Makefile
@@ -0,0 +1,17 @@
+#!/usr/bin/make -f
+include ../common.mk
+
+all: run check
+
+run: clean
+ dpkg-buildpackage -b -us -uc
+
+check:
+ grep -qe "^Depends: .*python3\(:any\)\? (<< 3\.[0-9]\+)" \
+ debian/foo/DEBIAN/control
+ grep -qe "^Depends: .*python3\(:any\)\? (>= 3\.[0-9]\+~)" \
+ debian/foo/DEBIAN/control
+
+clean:
+ ./debian/rules clean
+ rm -rf lib/Foo.egg-info build