summaryrefslogtreecommitdiffstats
path: root/tests/t306
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 16:08:06 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 16:08:06 +0000
commitba6d96469df143b52295f8e79da648bf8a597407 (patch)
tree5ea0c3374f5c53209ad02008dcdddfc8ccae92e5 /tests/t306
parentInitial commit. (diff)
downloaddh-python-ba6d96469df143b52295f8e79da648bf8a597407.tar.xz
dh-python-ba6d96469df143b52295f8e79da648bf8a597407.zip
Adding upstream version 5.20230130+deb12u1.upstream/5.20230130+deb12u1upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to '')
-rw-r--r--tests/t306/Makefile17
-rw-r--r--tests/t306/debian/changelog5
-rw-r--r--tests/t306/debian/compat1
-rw-r--r--tests/t306/debian/control13
-rw-r--r--tests/t306/debian/copyright2
-rwxr-xr-xtests/t306/debian/rules14
-rw-r--r--tests/t306/debian/source/format1
-rw-r--r--tests/t306/lib/__init__.py0
-rw-r--r--tests/t306/lib/bar.c0
-rw-r--r--tests/t306/lib/foo.py6
-rwxr-xr-xtests/t306/setup.py12
11 files changed, 71 insertions, 0 deletions
diff --git a/tests/t306/Makefile b/tests/t306/Makefile
new file mode 100644
index 0000000..9dbf8c4
--- /dev/null
+++ b/tests/t306/Makefile
@@ -0,0 +1,17 @@
+#!/usr/bin/make -f
+include ../common.mk
+
+all: run check
+
+run: clean
+ dpkg-buildpackage -b -us -uc
+
+check:
+ grep -qe "^Depends: .*python3\(:any\)\? (<< 3\.[0-9]\+)" \
+ debian/foo/DEBIAN/control
+ grep -qe "^Depends: .*python3\(:any\)\? (>= 3\.[0-9]\+~)" \
+ debian/foo/DEBIAN/control
+
+clean:
+ ./debian/rules clean
+ rm -rf lib/Foo.egg-info build
diff --git a/tests/t306/debian/changelog b/tests/t306/debian/changelog
new file mode 100644
index 0000000..874dc1d
--- /dev/null
+++ b/tests/t306/debian/changelog
@@ -0,0 +1,5 @@
+foo (0.1) unstable; urgency=low
+
+ * Initial release
+
+ -- Maximilian Engelhardt <maxi@daemonizer.de> Sun, 04 Apr 2021 13:09:48 +0200
diff --git a/tests/t306/debian/compat b/tests/t306/debian/compat
new file mode 100644
index 0000000..48082f7
--- /dev/null
+++ b/tests/t306/debian/compat
@@ -0,0 +1 @@
+12
diff --git a/tests/t306/debian/control b/tests/t306/debian/control
new file mode 100644
index 0000000..79446f3
--- /dev/null
+++ b/tests/t306/debian/control
@@ -0,0 +1,13 @@
+Source: foo
+Section: python
+Priority: optional
+Maintainer: Maximilian Engelhardt <maxi@daemonizer.de>
+Build-Depends: debhelper (>= 12.9), python3-all-dev:any
+Standards-Version: 4.5.1
+
+Package: foo
+Architecture: any
+Depends: ${python3:Depends}, ${shlibs:Depends}, ${misc:Depends}
+Description: package with python3-all-dev dependency using :any
+ example package #6 - private Python extensions and python3-all-dev:any
+ dependency
diff --git a/tests/t306/debian/copyright b/tests/t306/debian/copyright
new file mode 100644
index 0000000..32bbc0d
--- /dev/null
+++ b/tests/t306/debian/copyright
@@ -0,0 +1,2 @@
+The Debian packaging is © 2021, Maximilian Engelhardt <maxi@daemonizer.de> and
+is licensed under the MIT License.
diff --git a/tests/t306/debian/rules b/tests/t306/debian/rules
new file mode 100755
index 0000000..d1ffc6a
--- /dev/null
+++ b/tests/t306/debian/rules
@@ -0,0 +1,14 @@
+#!/usr/bin/make -f
+
+%:
+ dh $@ --buildsystem=none
+
+override_dh_install:
+ dh_install
+ DH_VERBOSE=1 ../../dh_python3
+
+override_dh_auto_build:
+ python3 setup.py build
+
+override_dh_auto_install:
+ python3 setup.py install --root=debian/foo/ --install-lib=/usr/share/foo/python
diff --git a/tests/t306/debian/source/format b/tests/t306/debian/source/format
new file mode 100644
index 0000000..89ae9db
--- /dev/null
+++ b/tests/t306/debian/source/format
@@ -0,0 +1 @@
+3.0 (native)
diff --git a/tests/t306/lib/__init__.py b/tests/t306/lib/__init__.py
new file mode 100644
index 0000000..e69de29
--- /dev/null
+++ b/tests/t306/lib/__init__.py
diff --git a/tests/t306/lib/bar.c b/tests/t306/lib/bar.c
new file mode 100644
index 0000000..e69de29
--- /dev/null
+++ b/tests/t306/lib/bar.c
diff --git a/tests/t306/lib/foo.py b/tests/t306/lib/foo.py
new file mode 100644
index 0000000..9dd52e6
--- /dev/null
+++ b/tests/t306/lib/foo.py
@@ -0,0 +1,6 @@
+import foo.bar
+
+
+class Foo(object):
+ def __init__(self):
+ foo.bar
diff --git a/tests/t306/setup.py b/tests/t306/setup.py
new file mode 100755
index 0000000..25727f2
--- /dev/null
+++ b/tests/t306/setup.py
@@ -0,0 +1,12 @@
+#! /usr/bin/python3
+from distutils.core import setup, Extension
+
+setup(name='Foo',
+ version='0.1',
+ description="package with private Python extension",
+ author='Maximilian Engelhardt',
+ author_email='maxi@daemonizer.de',
+ url='http://www.debian.org/',
+ ext_modules=[Extension('foo/bar', ['lib/bar.c'])],
+ packages=['foo'],
+ package_dir={'foo': 'lib'})