summaryrefslogtreecommitdiffstats
path: root/tests/ta02
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 16:08:06 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 16:08:06 +0000
commitba6d96469df143b52295f8e79da648bf8a597407 (patch)
tree5ea0c3374f5c53209ad02008dcdddfc8ccae92e5 /tests/ta02
parentInitial commit. (diff)
downloaddh-python-ba6d96469df143b52295f8e79da648bf8a597407.tar.xz
dh-python-ba6d96469df143b52295f8e79da648bf8a597407.zip
Adding upstream version 5.20230130+deb12u1.upstream/5.20230130+deb12u1upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'tests/ta02')
-rw-r--r--tests/ta02/Makefile17
-rw-r--r--tests/ta02/debian/changelog5
-rw-r--r--tests/ta02/debian/control16
-rwxr-xr-xtests/ta02/debian/rules28
-rw-r--r--tests/ta02/foo/__init__.py1
-rw-r--r--tests/ta02/pyproject.toml3
-rw-r--r--tests/ta02/setup.cfg10
-rw-r--r--tests/ta02/tests/__init__.py0
-rw-r--r--tests/ta02/tests/test_foo.py7
9 files changed, 87 insertions, 0 deletions
diff --git a/tests/ta02/Makefile b/tests/ta02/Makefile
new file mode 100644
index 0000000..f6c26ed
--- /dev/null
+++ b/tests/ta02/Makefile
@@ -0,0 +1,17 @@
+all: run check
+
+run:
+ @echo No build needed
+ifeq ($(AUTOPKGTEST_TMP),)
+ @echo NOTE this test uses the system pybuild-autopkgtest, not the working directory
+endif
+
+check:
+ DH_VERBOSE=1 pybuild-autopkgtest
+ test -e custom-test-executed
+
+clean:
+ ./debian/rules clean
+ifneq ($(AUTOPKGTEST_TMP),)
+ rm -r $(AUTOPKGTEST_TMP)/*
+endif
diff --git a/tests/ta02/debian/changelog b/tests/ta02/debian/changelog
new file mode 100644
index 0000000..322011c
--- /dev/null
+++ b/tests/ta02/debian/changelog
@@ -0,0 +1,5 @@
+foo (1.2.3) unstable; urgency=low
+
+ * Initial release
+
+ -- Piotr Ozarowski <piotr@debian.org> Tue, 02 Jul 2013 11:02:06 +0200
diff --git a/tests/ta02/debian/control b/tests/ta02/debian/control
new file mode 100644
index 0000000..648c259
--- /dev/null
+++ b/tests/ta02/debian/control
@@ -0,0 +1,16 @@
+Source: foo
+Section: python
+Priority: optional
+Maintainer: Piotr Ożarowski <piotr@debian.org>
+Build-Depends: debhelper-compat (= 12)
+ , pybuild-plugin-pyproject
+ , python3-all
+ , python3-pytest
+ , python3-setuptools
+Standards-Version: 3.9.4
+
+Package: python3-foo
+Architecture: any
+Depends: ${python3:Depends}, ${shlibs:Depends}, ${misc:Depends}
+Description: package with public CPython modules
+ example package #8
diff --git a/tests/ta02/debian/rules b/tests/ta02/debian/rules
new file mode 100755
index 0000000..b612080
--- /dev/null
+++ b/tests/ta02/debian/rules
@@ -0,0 +1,28 @@
+#!/usr/bin/make -f
+
+export PYBUILD_NAME=foo
+export PYBUILD_TEST_CUSTOM=1
+export PYBUILD_TEST_ARGS=touch {dir}/custom-test-executed
+
+%:
+ dh $@
+
+override_dh_auto_build:
+ ../../pybuild --build --verbose
+
+override_dh_auto_install:
+ ../../pybuild --install
+
+override_dh_auto_test:
+ ../../pybuild --test
+
+override_dh_auto_clean:
+ ../../pybuild --clean --verbose
+ rm -rf custom-test-executed foo.egg-info
+
+override_dh_installinit:
+ DH_VERBOSE=1 ../../dh_python3
+ dh_installinit
+
+override_dh_python3:
+ # ignore any system dh_python3
diff --git a/tests/ta02/foo/__init__.py b/tests/ta02/foo/__init__.py
new file mode 100644
index 0000000..92d9a9a
--- /dev/null
+++ b/tests/ta02/foo/__init__.py
@@ -0,0 +1 @@
+"Nothing here"
diff --git a/tests/ta02/pyproject.toml b/tests/ta02/pyproject.toml
new file mode 100644
index 0000000..9787c3b
--- /dev/null
+++ b/tests/ta02/pyproject.toml
@@ -0,0 +1,3 @@
+[build-system]
+requires = ["setuptools", "wheel"]
+build-backend = "setuptools.build_meta"
diff --git a/tests/ta02/setup.cfg b/tests/ta02/setup.cfg
new file mode 100644
index 0000000..877dcf7
--- /dev/null
+++ b/tests/ta02/setup.cfg
@@ -0,0 +1,10 @@
+[metadata]
+name = foo
+version = 0.1
+description = My package description
+long_description = My long description
+license = Expat
+
+[options]
+zip_safe = False
+packages = find:
diff --git a/tests/ta02/tests/__init__.py b/tests/ta02/tests/__init__.py
new file mode 100644
index 0000000..e69de29
--- /dev/null
+++ b/tests/ta02/tests/__init__.py
diff --git a/tests/ta02/tests/test_foo.py b/tests/ta02/tests/test_foo.py
new file mode 100644
index 0000000..2cac2b2
--- /dev/null
+++ b/tests/ta02/tests/test_foo.py
@@ -0,0 +1,7 @@
+import unittest
+
+class TestThatWeDontRunTheseTests(unittest.TestCase):
+
+ def test_fail(self):
+ # We want the custom test runner to run, not this test suite
+ self.assertTrue(False)