summaryrefslogtreecommitdiffstats
path: root/tests/tpb02
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 16:08:06 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 16:08:06 +0000
commitba6d96469df143b52295f8e79da648bf8a597407 (patch)
tree5ea0c3374f5c53209ad02008dcdddfc8ccae92e5 /tests/tpb02
parentInitial commit. (diff)
downloaddh-python-ba6d96469df143b52295f8e79da648bf8a597407.tar.xz
dh-python-ba6d96469df143b52295f8e79da648bf8a597407.zip
Adding upstream version 5.20230130+deb12u1.upstream/5.20230130+deb12u1upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'tests/tpb02')
-rw-r--r--tests/tpb02/Makefile19
-rw-r--r--tests/tpb02/data/share/man/man1/foo.18
-rw-r--r--tests/tpb02/debian/changelog5
-rw-r--r--tests/tpb02/debian/control16
-rw-r--r--tests/tpb02/debian/copyright2
-rw-r--r--tests/tpb02/debian/pybuild.testfiles3
-rwxr-xr-xtests/tpb02/debian/rules26
-rw-r--r--tests/tpb02/debian/source/format1
-rw-r--r--tests/tpb02/foo/__init__.py6
-rw-r--r--tests/tpb02/foo/test_foo.py11
-rw-r--r--tests/tpb02/nested/testfile2.txt0
-rw-r--r--tests/tpb02/pyproject.toml22
-rw-r--r--tests/tpb02/testdir/testfile3.txt0
-rw-r--r--tests/tpb02/testfile1.txt0
14 files changed, 119 insertions, 0 deletions
diff --git a/tests/tpb02/Makefile b/tests/tpb02/Makefile
new file mode 100644
index 0000000..3a86c66
--- /dev/null
+++ b/tests/tpb02/Makefile
@@ -0,0 +1,19 @@
+#!/usr/bin/make -f
+include ../common.mk
+
+DI=debian/python3-foo/usr/lib/python3/dist-packages/foo-0.1.dist-info
+
+check:
+ test -f debian/python3-foo/usr/lib/python3/dist-packages/foo/__init__.py
+ test -f debian/python3-foo/usr/bin/foo
+ grep -q ^foo/__init__.py, $(DI)/RECORD
+ test ! -f $(DI)/direct_url.json
+ grep -L ^foo-0.1.dist-info/direct_url.json, $(DI)/RECORD | grep -q RECORD
+ grep -q 'Depends:.*python3-tomli' debian/python3-foo/DEBIAN/control
+ grep -q 'Depends:.*python3-importlib-metadata \| python3 (>> 3\.5)' debian/python3-foo/DEBIAN/control
+ grep -L 'Depends:.*tox' debian/python3-foo/DEBIAN/control | grep -q control
+ find .pybuild -name test-executed | grep -q test-executed
+ test -f debian/python3-foo/usr/share/man/man1/foo.1.gz
+
+clean:
+ ./debian/rules clean
diff --git a/tests/tpb02/data/share/man/man1/foo.1 b/tests/tpb02/data/share/man/man1/foo.1
new file mode 100644
index 0000000..3bf5dce
--- /dev/null
+++ b/tests/tpb02/data/share/man/man1/foo.1
@@ -0,0 +1,8 @@
+.TH foo 1 "December 5 2022"
+.SH NAME
+foo \- An example
+.SH SYNOPSIS
+.B foo
+.SH DESCRIPTION
+.B foo
+says hi.
diff --git a/tests/tpb02/debian/changelog b/tests/tpb02/debian/changelog
new file mode 100644
index 0000000..322011c
--- /dev/null
+++ b/tests/tpb02/debian/changelog
@@ -0,0 +1,5 @@
+foo (1.2.3) unstable; urgency=low
+
+ * Initial release
+
+ -- Piotr Ozarowski <piotr@debian.org> Tue, 02 Jul 2013 11:02:06 +0200
diff --git a/tests/tpb02/debian/control b/tests/tpb02/debian/control
new file mode 100644
index 0000000..c775ede
--- /dev/null
+++ b/tests/tpb02/debian/control
@@ -0,0 +1,16 @@
+Source: foo
+Section: python
+Priority: optional
+Maintainer: Piotr Ożarowski <piotr@debian.org>
+Build-Depends: debhelper-compat (= 12)
+ , flit
+ , python3-all
+ , pybuild-plugin-pyproject
+# , dh-python
+Standards-Version: 3.9.4
+
+Package: python3-foo
+Architecture: all
+Depends: ${python3:Depends}, ${shlibs:Depends}, ${misc:Depends}
+Description: package with public CPython modules
+ example package #1
diff --git a/tests/tpb02/debian/copyright b/tests/tpb02/debian/copyright
new file mode 100644
index 0000000..f96adde
--- /dev/null
+++ b/tests/tpb02/debian/copyright
@@ -0,0 +1,2 @@
+The Debian packaging is © 2013, Piotr Ożarowski <piotr@debian.org> and
+is licensed under the MIT License.
diff --git a/tests/tpb02/debian/pybuild.testfiles b/tests/tpb02/debian/pybuild.testfiles
new file mode 100644
index 0000000..58c4d14
--- /dev/null
+++ b/tests/tpb02/debian/pybuild.testfiles
@@ -0,0 +1,3 @@
+testfile1.txt
+nested/testfile2.txt
+testdir
diff --git a/tests/tpb02/debian/rules b/tests/tpb02/debian/rules
new file mode 100755
index 0000000..e8953b0
--- /dev/null
+++ b/tests/tpb02/debian/rules
@@ -0,0 +1,26 @@
+#!/usr/bin/make -f
+
+export PYBUILD_NAME=foo
+
+%:
+ dh $@
+
+override_dh_auto_build:
+ ../../pybuild --build
+
+override_dh_auto_install:
+ ../../pybuild --install
+
+override_dh_auto_test:
+ ../../pybuild --test
+
+override_dh_auto_clean:
+ ../../pybuild --clean
+ rm -rf .pybuild foo.egg-info
+
+override_dh_installinit:
+ DH_VERBOSE=1 ../../dh_python3
+ dh_installinit
+
+override_dh_python3:
+ # ignore any system dh_python3
diff --git a/tests/tpb02/debian/source/format b/tests/tpb02/debian/source/format
new file mode 100644
index 0000000..89ae9db
--- /dev/null
+++ b/tests/tpb02/debian/source/format
@@ -0,0 +1 @@
+3.0 (native)
diff --git a/tests/tpb02/foo/__init__.py b/tests/tpb02/foo/__init__.py
new file mode 100644
index 0000000..f29ed43
--- /dev/null
+++ b/tests/tpb02/foo/__init__.py
@@ -0,0 +1,6 @@
+"""An amazing sample package!"""
+
+__version__ = '0.1'
+
+def main():
+ print("Hello There")
diff --git a/tests/tpb02/foo/test_foo.py b/tests/tpb02/foo/test_foo.py
new file mode 100644
index 0000000..174b86b
--- /dev/null
+++ b/tests/tpb02/foo/test_foo.py
@@ -0,0 +1,11 @@
+from unittest import TestCase
+
+
+class RequiredTest(TestCase):
+ def test_tests_are_executed(self):
+ open('test-executed', 'w').close()
+
+ def test_testfiles_exist(self):
+ open('testfile1.txt').close()
+ open('testfile2.txt').close()
+ open('testdir/testfile3.txt').close()
diff --git a/tests/tpb02/nested/testfile2.txt b/tests/tpb02/nested/testfile2.txt
new file mode 100644
index 0000000..e69de29
--- /dev/null
+++ b/tests/tpb02/nested/testfile2.txt
diff --git a/tests/tpb02/pyproject.toml b/tests/tpb02/pyproject.toml
new file mode 100644
index 0000000..a20e0e7
--- /dev/null
+++ b/tests/tpb02/pyproject.toml
@@ -0,0 +1,22 @@
+[build-system]
+requires = ["flit_core >=2,<4"]
+build-backend = "flit_core.buildapi"
+
+[tool.flit.metadata]
+module = "foo"
+author = "Stefano Rivera"
+requires = [
+ "tomli",
+ "importlib-metadata ; python_version < '3.5'"
+]
+
+[tool.flit.metadata.requires-extra]
+test = [
+ "tox",
+]
+
+[tool.flit.scripts]
+foo = "foo:main"
+
+[tool.flit.external-data]
+directory = "data"
diff --git a/tests/tpb02/testdir/testfile3.txt b/tests/tpb02/testdir/testfile3.txt
new file mode 100644
index 0000000..e69de29
--- /dev/null
+++ b/tests/tpb02/testdir/testfile3.txt
diff --git a/tests/tpb02/testfile1.txt b/tests/tpb02/testfile1.txt
new file mode 100644
index 0000000..e69de29
--- /dev/null
+++ b/tests/tpb02/testfile1.txt