summaryrefslogtreecommitdiffstats
path: root/pydist/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'pydist/Makefile')
-rw-r--r--pydist/Makefile18
1 files changed, 18 insertions, 0 deletions
diff --git a/pydist/Makefile b/pydist/Makefile
new file mode 100644
index 0000000..2932a45
--- /dev/null
+++ b/pydist/Makefile
@@ -0,0 +1,18 @@
+#!/usr/bin/make -f
+
+FALLBACK_FLAGS = $(shell dpkg-vendor --is ubuntu && echo '--ubuntu')
+
+all: cpython3_fallback README.PyDist.html
+
+clean:
+ rm -rf cache
+ #rm -f dist_fallback
+ rm -f README.PyDist.html
+
+cpython3_fallback:
+ python3 ./generate_fallback_list.py $(FALLBACK_FLAGS)
+
+README.PyDist.html: README.PyDist
+ rst2html $< $@
+
+.PHONY: clean