summaryrefslogtreecommitdiffstats
path: root/tests/common.mk
diff options
context:
space:
mode:
Diffstat (limited to 'tests/common.mk')
-rw-r--r--tests/common.mk19
1 files changed, 19 insertions, 0 deletions
diff --git a/tests/common.mk b/tests/common.mk
new file mode 100644
index 0000000..b4d4f02
--- /dev/null
+++ b/tests/common.mk
@@ -0,0 +1,19 @@
+#!/usr/bin/make -f
+
+export DEBPYTHON3_DEFAULT ?= $(shell python3 ../../dhpython/_defaults.py default cpython3)
+export DEBPYTHON3_SUPPORTED ?= $(shell python3 ../../dhpython/_defaults.py supported cpython3)
+export DEB_HOST_MULTIARCH=my_multiarch-triplet
+export DEB_HOST_ARCH ?= $(shell dpkg-architecture -qDEB_HOST_ARCH)
+export DH_INTERNAL_OPTIONS=
+
+all: run check
+
+run: clean
+ @echo ============================================================
+ @echo ==== TEST: `basename $$PWD`
+ dpkg-buildpackage -b -us -uc \
+ --no-check-builddeps \
+ --check-command="../test-package-show-info"
+
+clean-common:
+ ./debian/rules clean