summaryrefslogtreecommitdiffstats
path: root/tests/t303
diff options
context:
space:
mode:
Diffstat (limited to 'tests/t303')
-rw-r--r--tests/t303/Makefile12
-rw-r--r--tests/t303/debian/changelog5
-rw-r--r--tests/t303/debian/compat1
-rw-r--r--tests/t303/debian/control12
-rw-r--r--tests/t303/debian/copyright2
-rwxr-xr-xtests/t303/debian/rules23
-rw-r--r--tests/t303/debian/source/format1
7 files changed, 56 insertions, 0 deletions
diff --git a/tests/t303/Makefile b/tests/t303/Makefile
new file mode 100644
index 0000000..9f2c71b
--- /dev/null
+++ b/tests/t303/Makefile
@@ -0,0 +1,12 @@
+#!/usr/bin/make -f
+include ../common.mk
+
+check:
+ test -f debian/python3-foo/usr/lib/python3/dist-packages/foo.py
+ test ! -d debian/python3-foo/usr/lib/python3.*/site-packages
+ grep -q 'py3compile -p python3-foo\s*$$' debian/python3-foo/DEBIAN/postinst
+ grep -q 'pypy3compile -p python3-foo\s*||\s*true$$' debian/python3-foo/DEBIAN/postinst
+ grep -q 'py3clean -p python3-foo\s*$$' debian/python3-foo/DEBIAN/prerm
+
+clean:
+ ./debian/rules clean
diff --git a/tests/t303/debian/changelog b/tests/t303/debian/changelog
new file mode 100644
index 0000000..1a796a1
--- /dev/null
+++ b/tests/t303/debian/changelog
@@ -0,0 +1,5 @@
+foo (0.1.1) unstable; urgency=low
+
+ * Initial release
+
+ -- Piotr Ożarowski <piotr@debian.org> Thu, 06 Jan 2011 17:23:23 +0100
diff --git a/tests/t303/debian/compat b/tests/t303/debian/compat
new file mode 100644
index 0000000..ec63514
--- /dev/null
+++ b/tests/t303/debian/compat
@@ -0,0 +1 @@
+9
diff --git a/tests/t303/debian/control b/tests/t303/debian/control
new file mode 100644
index 0000000..beb1372
--- /dev/null
+++ b/tests/t303/debian/control
@@ -0,0 +1,12 @@
+Source: foo
+Section: python
+Priority: optional
+Maintainer: Piotr Ożarowski <piotr@debian.org>
+Build-Depends: debhelper (>= 7.0.50~), python3-all-dev
+Standards-Version: 3.9.1
+
+Package: python3-foo
+Architecture: all
+Depends: ${python3:Depends}, ${shlibs:Depends}, ${misc:Depends}
+Description: package with public Python 3 modules
+ example package #4 - fix_locations test
diff --git a/tests/t303/debian/copyright b/tests/t303/debian/copyright
new file mode 100644
index 0000000..69cea75
--- /dev/null
+++ b/tests/t303/debian/copyright
@@ -0,0 +1,2 @@
+The Debian packaging is © 2011, Piotr Ożarowski <piotr@debian.org> and
+is licensed under the MIT License.
diff --git a/tests/t303/debian/rules b/tests/t303/debian/rules
new file mode 100755
index 0000000..8f0c8be
--- /dev/null
+++ b/tests/t303/debian/rules
@@ -0,0 +1,23 @@
+#!/usr/bin/make -f
+
+%:
+ dh $@
+
+override_dh_install:
+ dh_install
+ DH_VERBOSE=1 ../../dh_python3
+
+override_dh_auto_build:
+override_dh_auto_test:
+
+comma:=,
+empty:=
+space:= $(empty) $(empty)
+PYTHONS=$(subst $(comma),$(space),$(DEBPYTHON3_SUPPORTED))
+override_dh_auto_install:
+ set -e; for ver in $(PYTHONS); do\
+ mkdir -p debian/python3-foo/usr/lib/python$$ver/site-packages/;\
+ echo "print('foo')" > debian/python3-foo/usr/lib/python$$ver/site-packages/foo.py;\
+ done
+
+override_dh_auto_clean:
diff --git a/tests/t303/debian/source/format b/tests/t303/debian/source/format
new file mode 100644
index 0000000..89ae9db
--- /dev/null
+++ b/tests/t303/debian/source/format
@@ -0,0 +1 @@
+3.0 (native)