summaryrefslogtreecommitdiffstats
path: root/tests/t306/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'tests/t306/debian/rules')
-rwxr-xr-xtests/t306/debian/rules14
1 files changed, 14 insertions, 0 deletions
diff --git a/tests/t306/debian/rules b/tests/t306/debian/rules
new file mode 100755
index 0000000..d1ffc6a
--- /dev/null
+++ b/tests/t306/debian/rules
@@ -0,0 +1,14 @@
+#!/usr/bin/make -f
+
+%:
+ dh $@ --buildsystem=none
+
+override_dh_install:
+ dh_install
+ DH_VERBOSE=1 ../../dh_python3
+
+override_dh_auto_build:
+ python3 setup.py build
+
+override_dh_auto_install:
+ python3 setup.py install --root=debian/foo/ --install-lib=/usr/share/foo/python