summaryrefslogtreecommitdiffstats
path: root/tests/t306/setup.py
diff options
context:
space:
mode:
Diffstat (limited to '')
-rwxr-xr-xtests/t306/setup.py12
1 files changed, 12 insertions, 0 deletions
diff --git a/tests/t306/setup.py b/tests/t306/setup.py
new file mode 100755
index 0000000..25727f2
--- /dev/null
+++ b/tests/t306/setup.py
@@ -0,0 +1,12 @@
+#! /usr/bin/python3
+from distutils.core import setup, Extension
+
+setup(name='Foo',
+ version='0.1',
+ description="package with private Python extension",
+ author='Maximilian Engelhardt',
+ author_email='maxi@daemonizer.de',
+ url='http://www.debian.org/',
+ ext_modules=[Extension('foo/bar', ['lib/bar.c'])],
+ packages=['foo'],
+ package_dir={'foo': 'lib'})