summaryrefslogtreecommitdiffstats
path: root/tests/ta02/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'tests/ta02/Makefile')
-rw-r--r--tests/ta02/Makefile17
1 files changed, 17 insertions, 0 deletions
diff --git a/tests/ta02/Makefile b/tests/ta02/Makefile
new file mode 100644
index 0000000..f6c26ed
--- /dev/null
+++ b/tests/ta02/Makefile
@@ -0,0 +1,17 @@
+all: run check
+
+run:
+ @echo No build needed
+ifeq ($(AUTOPKGTEST_TMP),)
+ @echo NOTE this test uses the system pybuild-autopkgtest, not the working directory
+endif
+
+check:
+ DH_VERBOSE=1 pybuild-autopkgtest
+ test -e custom-test-executed
+
+clean:
+ ./debian/rules clean
+ifneq ($(AUTOPKGTEST_TMP),)
+ rm -r $(AUTOPKGTEST_TMP)/*
+endif