summaryrefslogtreecommitdiffstats
path: root/tests/tpb03/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'tests/tpb03/debian/rules')
-rwxr-xr-xtests/tpb03/debian/rules26
1 files changed, 26 insertions, 0 deletions
diff --git a/tests/tpb03/debian/rules b/tests/tpb03/debian/rules
new file mode 100755
index 0000000..e8953b0
--- /dev/null
+++ b/tests/tpb03/debian/rules
@@ -0,0 +1,26 @@
+#!/usr/bin/make -f
+
+export PYBUILD_NAME=foo
+
+%:
+ dh $@
+
+override_dh_auto_build:
+ ../../pybuild --build
+
+override_dh_auto_install:
+ ../../pybuild --install
+
+override_dh_auto_test:
+ ../../pybuild --test
+
+override_dh_auto_clean:
+ ../../pybuild --clean
+ rm -rf .pybuild foo.egg-info
+
+override_dh_installinit:
+ DH_VERBOSE=1 ../../dh_python3
+ dh_installinit
+
+override_dh_python3:
+ # ignore any system dh_python3