summaryrefslogtreecommitdiffstats
path: root/tests/tpb04/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'tests/tpb04/debian/rules')
-rwxr-xr-xtests/tpb04/debian/rules27
1 files changed, 27 insertions, 0 deletions
diff --git a/tests/tpb04/debian/rules b/tests/tpb04/debian/rules
new file mode 100755
index 0000000..1a4e00b
--- /dev/null
+++ b/tests/tpb04/debian/rules
@@ -0,0 +1,27 @@
+#!/usr/bin/make -f
+
+export PYBUILD_NAME=foo
+export PYBUILD_EXT_DESTDIR_python3=debian/python3-foo-ext
+
+%:
+ dh $@
+
+override_dh_auto_build:
+ ../../pybuild --build
+
+override_dh_auto_install:
+ ../../pybuild --install
+
+override_dh_auto_test:
+ ../../pybuild --test --test-tox --test-args=-v
+
+override_dh_auto_clean:
+ ../../pybuild --clean
+ rm -rf .pybuild .tox foo.egg-info test-executed
+
+override_dh_installinit:
+ DH_VERBOSE=1 ../../dh_python3
+ dh_installinit
+
+override_dh_python3:
+ # ignore any system dh_python3