summaryrefslogtreecommitdiffstats
path: root/tests/tpb05
diff options
context:
space:
mode:
Diffstat (limited to 'tests/tpb05')
-rw-r--r--tests/tpb05/LICENSE17
-rw-r--r--tests/tpb05/Makefile19
-rw-r--r--tests/tpb05/debian/changelog5
-rw-r--r--tests/tpb05/debian/control16
-rw-r--r--tests/tpb05/debian/copyright2
-rwxr-xr-xtests/tpb05/debian/rules28
-rw-r--r--tests/tpb05/debian/source/format1
-rw-r--r--tests/tpb05/foo/__init__.py4
-rw-r--r--tests/tpb05/foo/test_foo.py6
-rw-r--r--tests/tpb05/pyproject.toml17
-rw-r--r--tests/tpb05/setup.py5
11 files changed, 120 insertions, 0 deletions
diff --git a/tests/tpb05/LICENSE b/tests/tpb05/LICENSE
new file mode 100644
index 0000000..5996299
--- /dev/null
+++ b/tests/tpb05/LICENSE
@@ -0,0 +1,17 @@
+Permission is hereby granted, free of charge, to any person obtaining a copy of
+this software and associated documentation files (the "Software"), to deal in
+the Software without restriction, including without limitation the rights to
+use, copy, modify, merge, publish, distribute, sublicense, and/or sell copies
+of the Software, and to permit persons to whom the Software is furnished to do
+so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in all
+copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING
+FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER
+DEALINGS IN THE SOFTWARE.
diff --git a/tests/tpb05/Makefile b/tests/tpb05/Makefile
new file mode 100644
index 0000000..b9bc2a5
--- /dev/null
+++ b/tests/tpb05/Makefile
@@ -0,0 +1,19 @@
+#!/usr/bin/make -f
+include ../common.mk
+
+DI=debian/python3-foo/usr/lib/python3/dist-packages/foo-0.1.dist-info
+
+check:
+ test -f debian/python3-foo/usr/lib/python3/dist-packages/foo/__init__.py
+ grep -q ^foo/__init__.py, $(DI)/RECORD
+ test ! -f $(DI)/direct_url.json
+ grep -L ^foo-0.1.dist-info/direct_url.json, $(DI)/RECORD | grep -q RECORD
+ grep -q 'Depends:.*python3-tomli' debian/python3-foo/DEBIAN/control
+ grep -q 'Depends:.*python3-importlib-metadata \| python3 (>> 3\.5)' debian/python3-foo/DEBIAN/control
+ grep -L 'Depends:.*tox' debian/python3-foo/DEBIAN/control | grep -q control
+ find .pybuild -name test-executed | grep -q test-executed
+ grep -q usr/bin/python3$$ debian/python3-foo/usr/bin/foo
+ find debian/python3-foo/usr/lib/python3/dist-packages/ -name LICENSE | { ! grep -q LICENSE; }
+
+clean:
+ ./debian/rules clean
diff --git a/tests/tpb05/debian/changelog b/tests/tpb05/debian/changelog
new file mode 100644
index 0000000..322011c
--- /dev/null
+++ b/tests/tpb05/debian/changelog
@@ -0,0 +1,5 @@
+foo (1.2.3) unstable; urgency=low
+
+ * Initial release
+
+ -- Piotr Ozarowski <piotr@debian.org> Tue, 02 Jul 2013 11:02:06 +0200
diff --git a/tests/tpb05/debian/control b/tests/tpb05/debian/control
new file mode 100644
index 0000000..76f5dbd
--- /dev/null
+++ b/tests/tpb05/debian/control
@@ -0,0 +1,16 @@
+Source: foo
+Section: python
+Priority: optional
+Maintainer: Piotr Ożarowski <piotr@debian.org>
+Build-Depends: debhelper-compat (= 12)
+ , python3-all
+ , python3-poetry-core
+ , python3-pytest
+ , pybuild-plugin-pyproject
+Standards-Version: 3.9.4
+
+Package: python3-foo
+Architecture: all
+Depends: ${python3:Depends}, ${shlibs:Depends}, ${misc:Depends}
+Description: package with public CPython modules
+ example package #1
diff --git a/tests/tpb05/debian/copyright b/tests/tpb05/debian/copyright
new file mode 100644
index 0000000..f96adde
--- /dev/null
+++ b/tests/tpb05/debian/copyright
@@ -0,0 +1,2 @@
+The Debian packaging is © 2013, Piotr Ożarowski <piotr@debian.org> and
+is licensed under the MIT License.
diff --git a/tests/tpb05/debian/rules b/tests/tpb05/debian/rules
new file mode 100755
index 0000000..4923534
--- /dev/null
+++ b/tests/tpb05/debian/rules
@@ -0,0 +1,28 @@
+#!/usr/bin/make -f
+
+export PYBUILD_NAME=foo
+
+%:
+ dh $@
+
+override_dh_auto_build:
+ ../../pybuild --build --verbose
+ ../../pybuild --build --verbose
+
+override_dh_auto_install:
+ ../../pybuild --install
+ ../../pybuild --install
+
+override_dh_auto_test:
+ ../../pybuild --test --test-pytest
+
+override_dh_auto_clean:
+ ../../pybuild --clean --verbose
+ rm -rf .pybuild foo.egg-info
+
+override_dh_installinit:
+ DH_VERBOSE=1 ../../dh_python3
+ dh_installinit
+
+override_dh_python3:
+ # ignore any system dh_python3
diff --git a/tests/tpb05/debian/source/format b/tests/tpb05/debian/source/format
new file mode 100644
index 0000000..89ae9db
--- /dev/null
+++ b/tests/tpb05/debian/source/format
@@ -0,0 +1 @@
+3.0 (native)
diff --git a/tests/tpb05/foo/__init__.py b/tests/tpb05/foo/__init__.py
new file mode 100644
index 0000000..b3b7945
--- /dev/null
+++ b/tests/tpb05/foo/__init__.py
@@ -0,0 +1,4 @@
+"""An amazing sample package!"""
+
+def main():
+ print("Hello")
diff --git a/tests/tpb05/foo/test_foo.py b/tests/tpb05/foo/test_foo.py
new file mode 100644
index 0000000..bbe6954
--- /dev/null
+++ b/tests/tpb05/foo/test_foo.py
@@ -0,0 +1,6 @@
+from unittest import TestCase
+
+
+class RequiredTest(TestCase):
+ def test_tests_are_executed(self):
+ open('test-executed', 'w').close()
diff --git a/tests/tpb05/pyproject.toml b/tests/tpb05/pyproject.toml
new file mode 100644
index 0000000..cb6ebaa
--- /dev/null
+++ b/tests/tpb05/pyproject.toml
@@ -0,0 +1,17 @@
+[build-system]
+requires = ["poetry>=0.12"]
+build-backend = "poetry.core.masonry.api"
+
+[tool.poetry]
+name = "foo"
+description = "an example module"
+version = "0.1"
+authors = ["Stefano Rivera <stefanor@debian.org>"]
+license = "Expat"
+
+[tool.poetry.dependencies]
+tomli = "^1.0.0"
+importlib-metadata = { version="*", python = "<3.5" }
+
+[tool.poetry.scripts]
+foo = 'foo:main'
diff --git a/tests/tpb05/setup.py b/tests/tpb05/setup.py
new file mode 100644
index 0000000..6593127
--- /dev/null
+++ b/tests/tpb05/setup.py
@@ -0,0 +1,5 @@
+#!/usr/bin/python3
+import sys
+
+sys.stderr.write('setup.py was called. Use pep517 instead.\n')
+sys.exit(1)