summaryrefslogtreecommitdiffstats
path: root/tests/tpb07
diff options
context:
space:
mode:
Diffstat (limited to 'tests/tpb07')
-rw-r--r--tests/tpb07/Makefile11
-rw-r--r--tests/tpb07/bar/LICENSE17
-rw-r--r--tests/tpb07/bar/bar/__init__.py4
-rw-r--r--tests/tpb07/bar/pyproject.toml3
-rw-r--r--tests/tpb07/bar/setup.cfg17
-rw-r--r--tests/tpb07/debian/changelog5
-rw-r--r--tests/tpb07/debian/control21
-rw-r--r--tests/tpb07/debian/copyright2
-rwxr-xr-xtests/tpb07/debian/rules30
-rw-r--r--tests/tpb07/debian/source/format1
-rw-r--r--tests/tpb07/foo/LICENSE17
-rw-r--r--tests/tpb07/foo/foo/__init__.py4
-rw-r--r--tests/tpb07/foo/pyproject.toml3
-rw-r--r--tests/tpb07/foo/setup.cfg17
14 files changed, 152 insertions, 0 deletions
diff --git a/tests/tpb07/Makefile b/tests/tpb07/Makefile
new file mode 100644
index 0000000..5eb4f00
--- /dev/null
+++ b/tests/tpb07/Makefile
@@ -0,0 +1,11 @@
+#!/usr/bin/make -f
+include ../common.mk
+
+check:
+ test -f debian/python3-foo/usr/lib/python3/dist-packages/foo/__init__.py
+ test -f debian/python3-bar/usr/lib/python3/dist-packages/bar/__init__.py
+ test -f debian/python3-foo/usr/bin/foo
+ test -f debian/python3-bar/usr/bin/bar
+
+clean:
+ ./debian/rules clean
diff --git a/tests/tpb07/bar/LICENSE b/tests/tpb07/bar/LICENSE
new file mode 100644
index 0000000..5996299
--- /dev/null
+++ b/tests/tpb07/bar/LICENSE
@@ -0,0 +1,17 @@
+Permission is hereby granted, free of charge, to any person obtaining a copy of
+this software and associated documentation files (the "Software"), to deal in
+the Software without restriction, including without limitation the rights to
+use, copy, modify, merge, publish, distribute, sublicense, and/or sell copies
+of the Software, and to permit persons to whom the Software is furnished to do
+so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in all
+copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING
+FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER
+DEALINGS IN THE SOFTWARE.
diff --git a/tests/tpb07/bar/bar/__init__.py b/tests/tpb07/bar/bar/__init__.py
new file mode 100644
index 0000000..717b184
--- /dev/null
+++ b/tests/tpb07/bar/bar/__init__.py
@@ -0,0 +1,4 @@
+"""An amazing sample package!"""
+
+def main():
+ print("Hello I am bar")
diff --git a/tests/tpb07/bar/pyproject.toml b/tests/tpb07/bar/pyproject.toml
new file mode 100644
index 0000000..9787c3b
--- /dev/null
+++ b/tests/tpb07/bar/pyproject.toml
@@ -0,0 +1,3 @@
+[build-system]
+requires = ["setuptools", "wheel"]
+build-backend = "setuptools.build_meta"
diff --git a/tests/tpb07/bar/setup.cfg b/tests/tpb07/bar/setup.cfg
new file mode 100644
index 0000000..296c419
--- /dev/null
+++ b/tests/tpb07/bar/setup.cfg
@@ -0,0 +1,17 @@
+[metadata]
+name = bar
+version = 0.1
+description = My package description
+long_description = My long description
+license = Expat
+
+[options]
+zip_safe = False
+packages = find:
+install_requires =
+ tomli
+ importlib-metadata; python_version<'3.5'
+
+[options.entry_points]
+console_scripts =
+ bar = bar:main
diff --git a/tests/tpb07/debian/changelog b/tests/tpb07/debian/changelog
new file mode 100644
index 0000000..fa1a4b0
--- /dev/null
+++ b/tests/tpb07/debian/changelog
@@ -0,0 +1,5 @@
+foobar (1.2.3) unstable; urgency=low
+
+ * Initial release
+
+ -- Piotr Ozarowski <piotr@debian.org> Tue, 02 Jul 2013 11:02:06 +0200
diff --git a/tests/tpb07/debian/control b/tests/tpb07/debian/control
new file mode 100644
index 0000000..6631581
--- /dev/null
+++ b/tests/tpb07/debian/control
@@ -0,0 +1,21 @@
+Source: foobar
+Section: python
+Priority: optional
+Maintainer: Piotr Ożarowski <piotr@debian.org>
+Build-Depends: debhelper-compat (= 12)
+ , python3-all
+ , python3-setuptools
+ , pybuild-plugin-pyproject
+Standards-Version: 3.9.4
+
+Package: python3-foo
+Architecture: all
+Depends: ${python3:Depends}, ${misc:Depends}
+Description: package with public CPython modules
+ example package #1
+
+Package: python3-bar
+Architecture: all
+Depends: ${python3:Depends}, ${misc:Depends}
+Description: package with public CPython modules
+ example package #2
diff --git a/tests/tpb07/debian/copyright b/tests/tpb07/debian/copyright
new file mode 100644
index 0000000..f96adde
--- /dev/null
+++ b/tests/tpb07/debian/copyright
@@ -0,0 +1,2 @@
+The Debian packaging is © 2013, Piotr Ożarowski <piotr@debian.org> and
+is licensed under the MIT License.
diff --git a/tests/tpb07/debian/rules b/tests/tpb07/debian/rules
new file mode 100755
index 0000000..b93abef
--- /dev/null
+++ b/tests/tpb07/debian/rules
@@ -0,0 +1,30 @@
+#!/usr/bin/make -f
+
+export PYBUILD_NAME=foo
+
+%:
+ dh $@
+
+override_dh_auto_build:
+ ../../pybuild -d foo --build --verbose --name=foo
+ ../../pybuild -d bar --build --verbose --name=bar
+
+override_dh_auto_install:
+ ../../pybuild -d foo --install --name=foo
+ ../../pybuild -d bar --install --name=bar
+
+override_dh_auto_test:
+ ../../pybuild -d foo --test --name=foo
+ ../../pybuild -d bar --test --name=bar
+
+override_dh_auto_clean:
+ ../../pybuild -d foo --clean --verbose --name=foo
+ ../../pybuild -d bar --clean --verbose --name=bar
+ rm -rf .pybuild foo/foo.egg-info bar/bar.egg-info
+
+override_dh_installinit:
+ DH_VERBOSE=1 ../../dh_python3
+ dh_installinit
+
+override_dh_python3:
+ # ignore any system dh_python3
diff --git a/tests/tpb07/debian/source/format b/tests/tpb07/debian/source/format
new file mode 100644
index 0000000..89ae9db
--- /dev/null
+++ b/tests/tpb07/debian/source/format
@@ -0,0 +1 @@
+3.0 (native)
diff --git a/tests/tpb07/foo/LICENSE b/tests/tpb07/foo/LICENSE
new file mode 100644
index 0000000..5996299
--- /dev/null
+++ b/tests/tpb07/foo/LICENSE
@@ -0,0 +1,17 @@
+Permission is hereby granted, free of charge, to any person obtaining a copy of
+this software and associated documentation files (the "Software"), to deal in
+the Software without restriction, including without limitation the rights to
+use, copy, modify, merge, publish, distribute, sublicense, and/or sell copies
+of the Software, and to permit persons to whom the Software is furnished to do
+so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in all
+copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING
+FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER
+DEALINGS IN THE SOFTWARE.
diff --git a/tests/tpb07/foo/foo/__init__.py b/tests/tpb07/foo/foo/__init__.py
new file mode 100644
index 0000000..1421a55
--- /dev/null
+++ b/tests/tpb07/foo/foo/__init__.py
@@ -0,0 +1,4 @@
+"""An amazing sample package!"""
+
+def main():
+ print("Hello I am foo")
diff --git a/tests/tpb07/foo/pyproject.toml b/tests/tpb07/foo/pyproject.toml
new file mode 100644
index 0000000..9787c3b
--- /dev/null
+++ b/tests/tpb07/foo/pyproject.toml
@@ -0,0 +1,3 @@
+[build-system]
+requires = ["setuptools", "wheel"]
+build-backend = "setuptools.build_meta"
diff --git a/tests/tpb07/foo/setup.cfg b/tests/tpb07/foo/setup.cfg
new file mode 100644
index 0000000..3447fdc
--- /dev/null
+++ b/tests/tpb07/foo/setup.cfg
@@ -0,0 +1,17 @@
+[metadata]
+name = foo
+version = 0.1
+description = My package description
+long_description = My long description
+license = Expat
+
+[options]
+zip_safe = False
+packages = find:
+install_requires =
+ tomli
+ importlib-metadata; python_version<'3.5'
+
+[options.entry_points]
+console_scripts =
+ foo = foo:main