summaryrefslogtreecommitdiffstats
path: root/doc/example-config/Makefile.am
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 09:51:24 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 09:51:24 +0000
commitf7548d6d28c313cf80e6f3ef89aed16a19815df1 (patch)
treea3f6f2a3f247293bee59ecd28e8cd8ceb6ca064a /doc/example-config/Makefile.am
parentInitial commit. (diff)
downloaddovecot-upstream.tar.xz
dovecot-upstream.zip
Adding upstream version 1:2.3.19.1+dfsg1.upstream/1%2.3.19.1+dfsg1upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to '')
-rw-r--r--doc/example-config/Makefile.am28
1 files changed, 28 insertions, 0 deletions
diff --git a/doc/example-config/Makefile.am b/doc/example-config/Makefile.am
new file mode 100644
index 0000000..331d6e9
--- /dev/null
+++ b/doc/example-config/Makefile.am
@@ -0,0 +1,28 @@
+SUBDIRS = conf.d
+
+pkgsysconfdir = $(sysconfdir)/dovecot
+nodist_pkgsysconf_DATA = README
+# nodist_ prefix just doesn't seem to work, so rm it directly:
+dist-hook:
+ rm -f $(distdir)/README
+
+README: README.in Makefile
+ cat $(srcdir)/README.in | sed "s|@exampledir@|$(exampledir)|" > README
+
+exampledir = $(docdir)/example-config
+example_DATA = \
+ dovecot.conf \
+ dovecot-dict-auth.conf.ext \
+ dovecot-dict-sql.conf.ext \
+ dovecot-ldap.conf.ext \
+ dovecot-oauth2.conf.ext \
+ dovecot-sql.conf.ext
+
+EXTRA_DIST = \
+ $(example_DATA) \
+ README.in
+
+install-data-local:
+ $(mkdir_p) $(DESTDIR)/$(pkgsysconfdir)
+
+CLEANFILES = README