summaryrefslogtreecommitdiffstats
path: root/src/plugins/Makefile.am
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 09:51:24 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 09:51:24 +0000
commitf7548d6d28c313cf80e6f3ef89aed16a19815df1 (patch)
treea3f6f2a3f247293bee59ecd28e8cd8ceb6ca064a /src/plugins/Makefile.am
parentInitial commit. (diff)
downloaddovecot-f7548d6d28c313cf80e6f3ef89aed16a19815df1.tar.xz
dovecot-f7548d6d28c313cf80e6f3ef89aed16a19815df1.zip
Adding upstream version 1:2.3.19.1+dfsg1.upstream/1%2.3.19.1+dfsg1upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/plugins/Makefile.am')
-rw-r--r--src/plugins/Makefile.am53
1 files changed, 53 insertions, 0 deletions
diff --git a/src/plugins/Makefile.am b/src/plugins/Makefile.am
new file mode 100644
index 0000000..ab0b9d1
--- /dev/null
+++ b/src/plugins/Makefile.am
@@ -0,0 +1,53 @@
+if BUILD_ZLIB_PLUGIN
+ZLIB = zlib imap-zlib
+endif
+
+if BUILD_LUCENE
+FTS_LUCENE = fts-lucene
+endif
+
+if BUILD_SOLR
+FTS_SOLR = fts-solr
+endif
+
+if HAVE_APPARMOR
+APPARMOR = apparmor
+endif
+
+if HAVE_LUA
+MAIL_LUA = mail-lua
+endif
+
+SUBDIRS = \
+ acl \
+ imap-acl \
+ fts \
+ fts-squat \
+ last-login \
+ lazy-expunge \
+ listescape \
+ notify \
+ notify-status \
+ push-notification \
+ mail-log \
+ $(MAIL_LUA) \
+ mailbox-alias \
+ quota \
+ quota-clone \
+ imap-quota \
+ pop3-migration \
+ replication \
+ old-stats \
+ imap-old-stats \
+ mail-crypt \
+ trash \
+ virtual \
+ welcome \
+ $(ZLIB) \
+ $(FTS_LUCENE) \
+ $(FTS_SOLR) \
+ $(DICT_LDAP) \
+ $(APPARMOR) \
+ fs-compress \
+ var-expand-crypt \
+ charset-alias