summaryrefslogtreecommitdiffstats
path: root/src/imap-hibernate/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/imap-hibernate/Makefile.am')
-rw-r--r--src/imap-hibernate/Makefile.am27
1 files changed, 27 insertions, 0 deletions
diff --git a/src/imap-hibernate/Makefile.am b/src/imap-hibernate/Makefile.am
new file mode 100644
index 0000000..3641c90
--- /dev/null
+++ b/src/imap-hibernate/Makefile.am
@@ -0,0 +1,27 @@
+pkglibexecdir = $(libexecdir)/dovecot
+
+pkglibexec_PROGRAMS = imap-hibernate
+
+AM_CPPFLAGS = \
+ -I$(top_srcdir)/src/lib \
+ -I$(top_srcdir)/src/lib-settings \
+ -I$(top_srcdir)/src/lib-master \
+ -I$(top_srcdir)/src/lib-imap \
+ $(BINARY_CFLAGS)
+
+imap_hibernate_LDADD = $(LIBDOVECOT) \
+ $(BINARY_LDFLAGS)
+
+imap_hibernate_DEPENDENCIES = $(LIBDOVECOT_DEPS)
+
+imap_hibernate_SOURCES = \
+ imap-client.c \
+ imap-hibernate-client.c \
+ imap-hibernate-settings.c \
+ imap-master-connection.c \
+ main.c
+
+noinst_HEADERS = \
+ imap-client.h \
+ imap-hibernate-client.h \
+ imap-master-connection.h