summaryrefslogtreecommitdiffstats
path: root/src/plugins/trash/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--src/plugins/trash/Makefile.am23
1 files changed, 23 insertions, 0 deletions
diff --git a/src/plugins/trash/Makefile.am b/src/plugins/trash/Makefile.am
new file mode 100644
index 0000000..af15d13
--- /dev/null
+++ b/src/plugins/trash/Makefile.am
@@ -0,0 +1,23 @@
+AM_CPPFLAGS = \
+ -I$(top_srcdir)/src/lib \
+ -I$(top_srcdir)/src/lib-mail \
+ -I$(top_srcdir)/src/lib-index \
+ -I$(top_srcdir)/src/lib-storage \
+ -I$(top_srcdir)/src/plugins/quota
+
+NOPLUGIN_LDFLAGS =
+lib11_trash_plugin_la_LDFLAGS = -module -avoid-version
+
+module_LTLIBRARIES = \
+ lib11_trash_plugin.la
+
+if DOVECOT_PLUGIN_DEPS
+lib11_trash_plugin_la_LIBADD = \
+ ../quota/lib10_quota_plugin.la
+endif
+
+lib11_trash_plugin_la_SOURCES = \
+ trash-plugin.c
+
+noinst_HEADERS = \
+ trash-plugin.h