summaryrefslogtreecommitdiffstats
path: root/src/plugins/zlib/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--src/plugins/zlib/Makefile.am24
1 files changed, 24 insertions, 0 deletions
diff --git a/src/plugins/zlib/Makefile.am b/src/plugins/zlib/Makefile.am
new file mode 100644
index 0000000..45c3d76
--- /dev/null
+++ b/src/plugins/zlib/Makefile.am
@@ -0,0 +1,24 @@
+AM_CPPFLAGS = \
+ -I$(top_srcdir)/src/lib \
+ -I$(top_srcdir)/src/lib-master \
+ -I$(top_srcdir)/src/lib-mail \
+ -I$(top_srcdir)/src/lib-compression \
+ -I$(top_srcdir)/src/lib-index \
+ -I$(top_srcdir)/src/lib-storage \
+ -I$(top_srcdir)/src/lib-storage/index \
+ -I$(top_srcdir)/src/lib-storage/index/dbox-common
+
+NOPLUGIN_LDFLAGS =
+lib20_zlib_plugin_la_LDFLAGS = -module -avoid-version
+
+module_LTLIBRARIES = \
+ lib20_zlib_plugin.la
+
+lib20_zlib_plugin_la_LIBADD = \
+ ../../lib-compression/libcompression.la
+
+lib20_zlib_plugin_la_SOURCES = \
+ zlib-plugin.c
+
+noinst_HEADERS = \
+ zlib-plugin.h