summaryrefslogtreecommitdiffstats
path: root/configure
diff options
context:
space:
mode:
Diffstat (limited to '')
-rwxr-xr-xconfigure18
1 files changed, 18 insertions, 0 deletions
diff --git a/configure b/configure
new file mode 100755
index 0000000..894f6be
--- /dev/null
+++ b/configure
@@ -0,0 +1,18 @@
+#!/bin/sh
+srcdir=$(cd $(dirname $0); pwd -P)
+
+if [ "$srcdir" = "$(pwd -P)" ]; then
+ # We're not in a separate build dir, but in the source dir, we already
+ # have a Makefile.
+ exit 0
+fi
+
+cat > Makefile <<EOF
+srcdir:=$srcdir
+
+default:
+ \$(MAKE) -f \$(srcdir)/Makefile srcdir=\$(srcdir)
+
+%:
+ \$(MAKE) -f \$(srcdir)/Makefile srcdir=\$(srcdir) \$*
+EOF