summaryrefslogtreecommitdiffstats
path: root/keyspan_pda/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 12:26:09 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 12:26:09 +0000
commit39a0d9019076a29a57a38a817b1830aef0708c11 (patch)
treed839d866a9986b99e90cd600f6874fae2f712be9 /keyspan_pda/Makefile
parentInitial commit. (diff)
downloadfirmware-nonfree-39a0d9019076a29a57a38a817b1830aef0708c11.tar.xz
firmware-nonfree-39a0d9019076a29a57a38a817b1830aef0708c11.zip
Adding upstream version 20230210.upstream/20230210upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'keyspan_pda/Makefile')
-rw-r--r--keyspan_pda/Makefile12
1 files changed, 12 insertions, 0 deletions
diff --git a/keyspan_pda/Makefile b/keyspan_pda/Makefile
new file mode 100644
index 0000000..fc37ea4
--- /dev/null
+++ b/keyspan_pda/Makefile
@@ -0,0 +1,12 @@
+CC = gcc
+IHEX2FW = ihex2fw
+
+all: keyspan_pda.fw xircom_pgs.fw
+
+%.fw: %.S
+ $(CC) -x assembler-with-cpp -P -E -o $*.asm $<
+ as31 -l $*.asm
+ $(IHEX2FW) $*.hex $@
+
+clean:
+ rm -f *.asm *.fw *.hex *.lst *.obj