summaryrefslogtreecommitdiffstats
path: root/carl9170fw/minifw/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'carl9170fw/minifw/CMakeLists.txt')
-rw-r--r--carl9170fw/minifw/CMakeLists.txt20
1 files changed, 20 insertions, 0 deletions
diff --git a/carl9170fw/minifw/CMakeLists.txt b/carl9170fw/minifw/CMakeLists.txt
new file mode 100644
index 0000000..adf5e08
--- /dev/null
+++ b/carl9170fw/minifw/CMakeLists.txt
@@ -0,0 +1,20 @@
+cmake_minimum_required(VERSION 2.8)
+
+project(miniboot.fw)
+
+include("../extra/sh-elf-linux.cmake")
+include("../config.cmake")
+
+set(miniboot_src miniboot.S)
+set_source_files_properties(miniboot.S PROPERTIES LANGUAGE C)
+
+add_executable(miniboot.elf miniboot.S)
+
+set_target_properties(miniboot.elf PROPERTIES LINKER_LANGUAGE C)
+
+set_target_properties(miniboot.elf PROPERTIES LINK_FLAGS "-Tminiboot.lds")
+
+add_custom_target(
+ miniboot.fw ALL
+ ${OBJCOPY} --strip-unneeded -O binary -R .sram -R .eeprom -R .fwdsc miniboot.elf miniboot.fw
+ DEPENDS miniboot.elf)