summaryrefslogtreecommitdiffstats
path: root/tests/samples/module1_toml
diff options
context:
space:
mode:
Diffstat (limited to 'tests/samples/module1_toml')
-rw-r--r--tests/samples/module1_toml/EG_README.rst4
-rw-r--r--tests/samples/module1_toml/module1.py3
-rw-r--r--tests/samples/module1_toml/pyproject.toml12
3 files changed, 19 insertions, 0 deletions
diff --git a/tests/samples/module1_toml/EG_README.rst b/tests/samples/module1_toml/EG_README.rst
new file mode 100644
index 0000000..a742974
--- /dev/null
+++ b/tests/samples/module1_toml/EG_README.rst
@@ -0,0 +1,4 @@
+This is an example long description for tests to load.
+
+This file is `valid reStructuredText
+<http://docutils.sourceforge.net/docs/ref/rst/restructuredtext.html>`_.
diff --git a/tests/samples/module1_toml/module1.py b/tests/samples/module1_toml/module1.py
new file mode 100644
index 0000000..87f0370
--- /dev/null
+++ b/tests/samples/module1_toml/module1.py
@@ -0,0 +1,3 @@
+"""Example module"""
+
+__version__ = '0.1'
diff --git a/tests/samples/module1_toml/pyproject.toml b/tests/samples/module1_toml/pyproject.toml
new file mode 100644
index 0000000..740ec87
--- /dev/null
+++ b/tests/samples/module1_toml/pyproject.toml
@@ -0,0 +1,12 @@
+[build-system]
+requires = ["flit"]
+
+[tool.flit.metadata]
+module = "module1"
+author = "Sir Robin"
+author-email = "robin@camelot.uk"
+home-page = "http://github.com/sirrobin/module1"
+description-file = "EG_README.rst"
+
+[tool.flit.metadata.urls]
+Documentation = "https://example.com/module1"