summaryrefslogtreecommitdiffstats
path: root/src/modules/rlm_eap/types/rlm_eap_sim/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'src/modules/rlm_eap/types/rlm_eap_sim/configure.ac')
-rw-r--r--src/modules/rlm_eap/types/rlm_eap_sim/configure.ac37
1 files changed, 37 insertions, 0 deletions
diff --git a/src/modules/rlm_eap/types/rlm_eap_sim/configure.ac b/src/modules/rlm_eap/types/rlm_eap_sim/configure.ac
new file mode 100644
index 0000000..dceab35
--- /dev/null
+++ b/src/modules/rlm_eap/types/rlm_eap_sim/configure.ac
@@ -0,0 +1,37 @@
+AC_PREREQ([2.68])
+AC_INIT(rlm_eap_sim.c)
+AC_REVISION($Revision$)
+FR_INIT_MODULE([rlm_eap_sim])
+
+fail=
+mod_ldflags=
+mod_cflags=
+
+if test x$with_[]modname != xno; then
+
+ targetname=modname
+else
+ targetname=
+ echo \*\*\* module modname is disabled.
+fi
+
+if test x"$fail" != x""; then
+ if test x"${enable_strict_dependencies}" = x"yes"; then
+ AC_MSG_ERROR([set --without-]modname[ to disable it explicitly.])
+ else
+ AC_MSG_WARN([silently not building ]modname[.])
+ AC_MSG_WARN([FAILURE: ]modname[ requires: $fail.])
+ if test x"$headersuggestion" != x; then
+ AC_MSG_WARN([$headersuggestion])
+ fi
+ if test x"$libsuggestion" != x; then
+ AC_MSG_WARN([$libsuggestion])
+ fi
+ targetname=""
+ fi
+fi
+
+AC_SUBST(mod_ldflags)
+AC_SUBST(mod_cflags)
+AC_SUBST(targetname)
+AC_OUTPUT(all.mk)