summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--debian/changelog9
-rw-r--r--debian/control2
-rw-r--r--debian/gbp.conf2
-rwxr-xr-xdebian/rules5
4 files changed, 16 insertions, 2 deletions
diff --git a/debian/changelog b/debian/changelog
index 251e532..73a1fe7 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,12 @@
+icinga2 (2.13.6-2+deb12u1) bookworm; urgency=medium
+
+ * Team upload.
+ * Update branch in gbp.conf & Vcs-Git URL.
+ * Fix segfault on startup on ppc64el.
+ (closes: #1068473)
+
+ -- Bas Couwenberg <sebastic@debian.org> Sat, 06 Apr 2024 14:02:31 +0200
+
icinga2 (2.13.6-2) unstable; urgency=medium
* Team upload.
diff --git a/debian/control b/debian/control
index ce71e20..c7ca24f 100644
--- a/debian/control
+++ b/debian/control
@@ -31,7 +31,7 @@ Build-Depends: bash-completion,
tzdata
Standards-Version: 4.6.2
Vcs-Browser: https://salsa.debian.org/nagios-team/icinga2
-Vcs-Git: https://salsa.debian.org/nagios-team/icinga2.git
+Vcs-Git: https://salsa.debian.org/nagios-team/icinga2.git -b bookworm
Homepage: https://icinga.com
Rules-Requires-Root: no
diff --git a/debian/gbp.conf b/debian/gbp.conf
index e3daba6..b82b31a 100644
--- a/debian/gbp.conf
+++ b/debian/gbp.conf
@@ -6,7 +6,7 @@ upstream-branch = upstream
# The default name for the Debian branch is "master".
# Change it if the name is different (for instance, "debian/unstable").
-debian-branch = master
+debian-branch = bookworm
# git-import-orig uses the following names for the upstream tags.
# Change the value if you are not using git-import-orig
diff --git a/debian/rules b/debian/rules
index 9309792..bbf3e00 100755
--- a/debian/rules
+++ b/debian/rules
@@ -9,6 +9,11 @@ include /usr/share/dpkg/architecture.mk
export CTEST_OUTPUT_ON_FAILURE=1
+# Fix segfault on startup: #1068473
+ifneq (,$(filter $(DEB_HOST_ARCH), ppc64el))
+ export DEB_CXXFLAGS_MAINT_APPEND = -O1
+endif
+
ifneq (,$(filter $(DEB_HOST_ARCH), armel mips mipsel powerpc))
export DEB_LDFLAGS_MAINT_APPEND += -Wl,--no-as-needed -latomic -Wl,--as-needed
endif