summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules19
1 files changed, 19 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..b63d7f9
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,19 @@
+#!/usr/bin/make -f
+
+MODULE := audit
+DEBDIR := debian/icingaweb2-module-$(MODULE)
+
+%:
+ dh ${@}
+
+override_dh_auto_install:
+ mkdir -p $(DEBDIR)/usr/share/icingaweb2/modules/$(MODULE)
+ find . -maxdepth 1 -mindepth 1 -and -not -name debian -and -not -name ".git*" -and -not -name ".pc" -exec cp -a {} $(DEBDIR)/usr/share/icingaweb2/modules/$(MODULE) \;
+
+ # remove useless files
+ rm -f $(DEBDIR)/usr/share/icingaweb2/modules/$(MODULE)/README.md
+ find $(DEBDIR)/usr/share/icingaweb2/modules/$(MODULE) -name LICENSE -exec rm -f {} \;
+
+ # enable module
+ mkdir -p $(DEBDIR)/etc/icingaweb2/enabledModules
+ ln -s /usr/share/icingaweb2/modules/$(MODULE) $(DEBDIR)/etc/icingaweb2/enabledModules/$(MODULE)